Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment :
Pack PlayStation : Spider-Man Miles Morales PS5 + ...
Voir le deal
99.99 €

Companion 2.1 je ne comprends pas tout

+5
Kilrah
dev.fred
jeta0357
Sacre100
pat31
9 participants

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Eric84AMC Mer 5 Aoû 2015 - 14:49

+1

Je trouve bizarre que les sons système ne soit pas les mêmes. Pour les chronos les minutes ou secondes se sont transformé en tension il me semble.
Avec les bons sons c'est OK mais la voix est moins claire.

En tout cas cela ne me dérange pas plus que cela. Au pire je ferais comme @pp340.
Eric84AMC
Eric84AMC

Masculin Messages : 2045
Date d'inscription : 21/09/2013
Age : 47
Localisation : Monteux

http://www.amc-pernes-lesvalayans.com/index.php

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mer 5 Aoû 2015 - 15:16

Je peux me gourer mais il me semble que pour 2.0 quelqu'un avait fait des annonces "à la main" alors que maintenant on a que les autogénérés qui sont à jour.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Jeu 6 Aoû 2015 - 15:14

Je suis en train de refaire la mise à jour des sons. Je m'aperçoit de différence entre le fichier french-taranis.csv et le french-taranis.zip. Par exemple dans le CSV le "0130" c'est "mètres" et le "0130.wav" c'est "Pied par seconde". Et il y en a d'autres ainsi. Bref je les vérifie un par un en comparant.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Jeu 6 Aoû 2015 - 15:42

Y me semble que le csv n'est plus valide...

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Jeu 6 Aoû 2015 - 18:40

J'ai aussi constaté un autre problème avec le Wizard dans la partie plane.lua pour l'instant. Dans le choix des options (ex. ailerons oui/non/2 canaux) on ne peut pas se déplacer avec le bouton rotatif de la Taranis-E.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Jeu 6 Aoû 2015 - 18:41

Kilrah a écrit:Y me semble que le csv n'est plus valide...

A mettre à jour donc...

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Ven 7 Aoû 2015 - 9:28

Et le problème de l'écran d'accueil décalé suite à l'installation de la version 2.1.1 ?

Companion 2.1 je ne comprends pas tout - Page 3 P1010121

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Ven 7 Aoû 2015 - 11:54

C'est peut-être bien un bug, j'ai constaté aussi un pb de décalage en faisant tourner l'exemple d'affichage graphique de notes en 2.1.1
https://frskytaranis.forumactif.org/t2311p30-tuto-affichage-automatique-d-une-page-de-notes-dans-la-taranis#28394
J'ai un décalage à droite de 30 pixels quand j'affiche une image sur la X9D.
Mais comme je suis dans un script LUA, je peux contourner le pb.


Problème local dans mon script de test.


Dernière édition par dev.fred le Ven 7 Aoû 2015 - 14:01, édité 1 fois

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Sacre100 Ven 7 Aoû 2015 - 12:11

dev.fred a écrit:C'est peut-être bien un bug, j'ai constaté aussi un pb de décalage en faisant tourner l'exemple d'affichage graphique de notes en 2.1.1
https://frskytaranis.forumactif.org/t2311p30-tuto-affichage-automatique-d-une-page-de-notes-dans-la-taranis#28394
J'ai un décalage à droite de 30 pixels quand j'affiche une image sur la X9D.
Mais comme je suis dans un script LUA, je peux contourner le pb.

Vaudrait mieux signaler le bug sur Github que de contourner le problème. C'est peut-être seulement dans la version française que le problème se produit car je n'ai encore rien vu sur RCG, OpenRcForum ou Github.
Sacre100
Sacre100

Masculin Messages : 1889
Date d'inscription : 30/11/2013
Age : 64
Localisation : Blonay - Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Ven 7 Aoû 2015 - 12:25

C'est moi qui ai buggé ! Embarassed , il n'y a pas de pb de décalage en dehors de mon script de test.

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Ven 7 Aoû 2015 - 18:02

Voilà pour ceux qui veulent tester les annonces /fr/SYSTEM/.
https://www.dropbox.com/s/d6nntaorq6yi7ez/french-taranis.zip?dl=0
J'ai fait au mieux mais faites quand même une sauvegarde de votre dossier actuel.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Eric84AMC Ven 7 Aoû 2015 - 20:30

Merci Murphy pour ton fichier. J'essaye cela la semaine prochaine.
Eric84AMC
Eric84AMC

Masculin Messages : 2045
Date d'inscription : 21/09/2013
Age : 47
Localisation : Monteux

http://www.amc-pernes-lesvalayans.com/index.php

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 11 Aoû 2015 - 15:40

bonjour,
Sauriez vous ou je pourrais trouver les code ID des capteurs ?
J'ai un FLVSS et un ZAGGO. Les deux ont bien été détecté sauf que j'utilisais A2 sur le ZAGGO et là j'utilise VFAs. Il y a une petite différence entre les deux. De plus je voudrais récupérer l'altitude et la qualité du GPS ... Pour cela il me faudrait les ID (je ne parle pas du domaine ID, celui là je l'ai deja).
Je pense que la valeur A2 d'un capteur X et la valeur A2 d'un capteur Y doit être la même. On interroge juste le domaine ID pour savoir à quel hardware on récupère la donnée.
Si quelqu'un a quelque chose ça serait vraiment super.
merci ;-)

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 11 Aoû 2015 - 16:23

Si A2 (ou autre) n'apparaît pas c'est qu'il n'est pas envoyé par le capteur.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par nicephore Mar 11 Aoû 2015 - 16:27

aurel a écrit:bonjour,
Sauriez vous ou je pourrais trouver les code ID des capteurs ?
J'ai un FLVSS et un ZAGGO. Les deux ont bien été détecté sauf que j'utilisais  A2 sur le ZAGGO et là j'utilise VFAs. Il y a une petite différence entre les deux. De plus je voudrais récupérer l'altitude et la qualité du GPS ... Pour cela il me faudrait les ID (je ne parle pas du domaine ID, celui là je l'ai deja).
Je pense que la valeur  A2 d'un capteur X et la valeur A2 d'un capteur Y doit être la même. On interroge juste le domaine ID pour savoir à quel hardware on récupère la donnée.
Si quelqu'un a quelque chose ça serait vraiment super.
merci ;-)

Hello Aurel,
Ce que tu recherche, c'est bien ça : https://frskytaranis.forumactif.org/t1873-variables-utilisable-en-lua ?

nicephore

Masculin Messages : 612
Date d'inscription : 14/06/2014
Localisation : Créteil

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Mar 11 Aoû 2015 - 17:59

Si tu cherches les physicasl ID's des capteurs ou instances utilisés dans l'écran de télémétrie, c'est là
https://frskytaranis.forumactif.org/t2459p15-presentation-de-la-telemetrie-opentx-2-1-traduction-de-opentx-2-1-telemetry-system-preview

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Sacre100 Mar 11 Aoû 2015 - 20:41

dev.fred a écrit:Si tu cherches les physicasl ID's des capteurs ou instances utilisés dans l'écran de télémétrie, c'est là
https://frskytaranis.forumactif.org/t2459p15-presentation-de-la-telemetrie-opentx-2-1-traduction-de-opentx-2-1-telemetry-system-preview

Cette liste est celle utilisée par les capteurs Frsky mais il y en a d'autres disponibles et utilisés par certain capteurs comme openXsensor.
Sacre100
Sacre100

Masculin Messages : 1889
Date d'inscription : 30/11/2013
Age : 64
Localisation : Blonay - Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Mar 11 Aoû 2015 - 21:56

Si tu as d'autres physicals ID, n’hésite pas à renseigner ta liste, c'est de l'info précieuse Companion 2.1 je ne comprends pas tout - Page 3 2258904616

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 11 Aoû 2015 - 22:02

Pour le Zaggo j'ai :
lipo ou VFas => 0210
Hdg => 0840

J'ai testé :
0025 pour A2, ça marche pas
0820 pour Galt ça marche pas
J'ai tenté un 0300 pour récupérer la même valeur que le FLVSS, ça marche pas non plus.
0400 et 0410 pour T1/T2 niette aussi. Par contre ceux là, il me les avait configuré mais l'unité était en °C. J'ai remis en RAW pour voir et rien du tout, affichage 0.

J'ai un TxBT (F103) qui correspond à je ne sais trop quoi. Ce n'est ni la LIPO ni l'accu de la radio .... Ca me gave ce truc là. Le pire c'est qu'on trouve rien sur le net.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Mar 11 Aoû 2015 - 22:34

C'est Frsky qui détient ces infos et ils demandent de signer un accord de confidentialité aux développeurs qui doivent expliquer leur projet avant de pouvoir accéder à un ficher contenant le détail de leur protocole.

La seule info dispo sur le forum frsky est cette image (google ne va pas trouver les mots clés la dedans) et c'est maigre:

Companion 2.1 je ne comprends pas tout - Page 3 A7108910

Sacre100 en a trouvé bien + en fouillant dans le code source dispo sur github (au passage les  physicals ID sont décalés de 1/ infos frsky)

Maintenant, à part bug ou capteurs inconnus, on ne devrait pas en avoir besoin, sinon pour décrypter les colonnes ID et Instance de l'écran de télémétrie, le système de reconnaissance de capteurs Frsky est PLUG and PLAY Companion 2.1 je ne comprends pas tout - Page 3 2258904616 .


Dernière édition par dev.fred le Mer 12 Aoû 2015 - 7:36, édité 1 fois

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Sacre100 Mer 12 Aoû 2015 - 0:12

dev.fred a écrit:Si tu as d'autres physicals ID, n’hésite pas à renseigner ta liste, c'est de l'info précieuse Companion 2.1 je ne comprends pas tout - Page 3 2258904616

Il y en a 28, voici la liste et leur affectation à ma connaissance (infos trouvée sur le net sans garantie).
Code:

// 0x00 / ID  1 - Vario
// 0xA1 / ID  2 - FLVSS utilisé aussi par MAVLink
// 0x22 / ID  3 - FAS-40S
// 0x83 / ID  4 - GPS
// 0xE4 / ID  5 - RPM
// 0x45 / ID  6 - SP2UART(Host) utilisé aussi par SM-Modellbau GPS Logger
// 0xC6 / ID  7 - SPUART(Remote)
// 0x67 / ID  8 - ??? (semble utilisé)
// 0x48 / ID  9 - Libre à priori
// 0xE9 / ID 10 - Airspeed
// 0x6A / ID 11 - Libre à priori
// 0xCB / ID 12 - Libre à priori
// 0xAC / ID 13 - Libre à priori
// 0x0D / ID 14 - ??? (semble utilisé)
// 0x8E / ID 15 - Libre à priori
// 0x2F / ID 16 - Libre à priori
// 0xD0 / ID 17 - Libre à priori
// 0x71 / ID 18 - Libre à priori
// 0xF2 / ID 19 - Libre à priori
// 0x53 / ID 20 - Utilisé par SM-Modellbau Unisens E
// 0x34 / ID 21 - Utilisé par N2 Industries MiniHub+
// 0x95 / ID 22 - Libre à priori
// 0x16 / ID 23 - Libre à priori
// 0xB7 / ID 24 - ??? (semble utilisé)
// 0x98 / ID 25 - ??? (semble utilisé)
// 0x39 / ID 26 - Tx & Rx
// 0xBA / ID 27 - ??? (semble utilisé)
// 0x1B / ID 28 - Utilisé par openXSensor et d'autre librairie
Sacre100
Sacre100

Masculin Messages : 1889
Date d'inscription : 30/11/2013
Age : 64
Localisation : Blonay - Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mer 12 Aoû 2015 - 10:43

Bonjour,

Où en dehors du forum, un acheteur lambda peut trouver ces renseignements. Je dis cela car hier j'ai reçu un mail de quelqu'un qui vient de commander une X9E et me demande des renseignements sur le firmware 2.1 qui est livré avec. Il ne connais pas OpenTX. En fait il me demande où charger une doc sur la Taranis X9E !

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mer 12 Aoû 2015 - 14:18

Il n'y a simplement pas de raison pour un utilisateur lambda de connaître ces infos...


Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mer 12 Aoû 2015 - 14:22

aurel a écrit:Pour le Zaggo j'ai :
lipo ou VFas => 0210
Hdg => 0840

J'ai testé :
0025 pour A2, ça marche pas
0820 pour Galt ça marche pas
Ce que tu fais ne sert à rien comme j'ai expliqué, la radio n'envoie rien, elle ne fait que d'afficher ce qu'elle reçoit.

Si le capteur envoie un 0820 la radio affchera un GAlt, si elle reçoit un ID qu'elle connaît pas elle affichera le numéro, mais si il manque une valeur c'est uniquement que le capteur ne l'envoie pas. Y'a donc rien à faire sur la radio pour régler le prob, faut regarder côté capteur.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mer 12 Aoû 2015 - 14:29

Kilrah a écrit:Il n'y a simplement pas de raison pour un utilisateur lambda de connaître ces infos...


D'accord, je vais lui répondre qu'il n'a aucun souci à se faire et que tout marche du premier coup Companion 2.1 je ne comprends pas tout - Page 3 2258904616 On verra...

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 3 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 3 sur 4 Précédent  1, 2, 3, 4  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum