Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.

Companion 2.1 je ne comprends pas tout

+5
Kilrah
dev.fred
jeta0357
Sacre100
pat31
9 participants

Page 2 sur 4 Précédent  1, 2, 3, 4  Suivant

Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 12:21

pat31 a écrit:
Murphy a écrit:Je continue et ça ne marche pas entre la X9D et la X9E.


- Je débranche la X9D et branche la X9E par l'USB.
-
.

Bonjour à tous.
Bonjour Murphy
Je vais peut être dire une bêtise car je ne suis pas sur d'avoir tout compris, mais il y a quelque chose qui m'interpelle dans ta manip.
Dans les réglages de companion, dans "type de radio" la X9D et la X9E sont  différenciées
. Or  tu branches la X9E sur companion attribué à la X9D. Le pb vient peut être de ça ?

Ca je l'ai fait. N'importe comment une fois l'EEPROM de la X9D enregistré c'est fini je reste sur Companion 2.1 et le profil de la X9E.

Moi ce qui m'interpelle c'est que chaque fois que je redémarre avec une EEPROM vierge sur la X9E, que je veux créer un modèle directement sur Companion, que je flashe la X9E j'ai le message à l'allumage "EEPROM NON CONFORME, FORMATAGE..." ou quleque chose comme ça. Puis "GAZ TROP HAUT" et je suis obligé de calibrer les manches. Et quand la radio s'allume enfin la liste est vide à part "MODEL01" et rien de ce que j'ai créé. Bref c'est la bérézina et j'y comprend rien. Où est l'incompatibilité entre Companion et la X9E ?

Par contre ce soir je repasse la X9D sous 2.0.17 et je recharge l'EEPROM que j'ai sauvegardée.
Bref en fait je viens de le faire, ça m'a pris 5mn et ça s'est bien passé...


Dernière édition par Murphy le Mar 4 Aoû 2015 - 12:52, édité 1 fois

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 12:44

Bah désolé, mais pour moi la précaution doit primer sur la rapidité... la "longue attente" pour la release officielle n'est pas vraiment "priver certain du mode découverte des versions en cours", on n'est pas à une semaine près.

dev.fred a écrit:Pour les problèmes plus subtiles qui n'affectent que des fonctions précises, j'ai pu en tester quelques une
Toi tu as les compétences et le temps pour évaluer et valider le fonctionnement des différentes fonctions, peut-être même que tu suis le log des commits sur github pour voir sur quoi on a travaillé et donc ce qui est le plus nécessaire de vérifier, mais de nouveau n'oublie pas que tu fais partie des 5% qui en sont capables.

dev.fred a écrit:Si cela produit un crash de la Taranis, c'est le cas le plus sympa car il n'y a même pas de test à faire, il suffit de reprendre une version nightly antérieur; le bootloader est toujours indemne.
De nouveau, n'oublie pas que pour un utilisateur lambda flasher sa radio c'est pas forcément un truc anodin mais plutôt l'affaire d'une demi journée.


dev.fred a écrit:J'avais un peu l'impression de faire partie d'un projet formidable
Il est formidable, et c'est très excitant d'être dedans et de suivre au jour le jour c'est clair! Mais il faut garder en tête que très peu de monde est en fait désireux, capable voire même a un avantage à le suivre de si près. Ce qui est super, excitant et facile pour toi peut très facilement se transformer en cauchemar pour un autre s'il est poussé à s'aventurer un peu trop loin par rapport à ses propres compétences. Donc profite des nightly (et merci pour les bug reports, c'est tout le but!), mais garde les pour toi ou pour ceux qui ont une expérience de test ou développement.

C'est pas contre toi, c'est simplement le fruit de l'expérience. On a eu exactement le même problème à la sortie de 2.0, avec plusieurs gars très enthousiastes qui recommandaient à tort et à travers de mettre à jour tout de suite "parce que wow c'est tellement mieux (et c'est vrai!)", et 3 posts plus bas on voit un pauvre gars qui n'avait aucun besoin des nouvelles fonctions, qui a paumé ses 10 modèles qu'il avait mis des jours à programmer parce qu'il s'est fait entraîner et a suivi la recommandation aveuglément sans trop comprendre ce qu'il faisait, a pas vu/compris les conséquences et précautions à prendre ou n'a pas "fait juste" (c'est bien d'avertir et de dire "fais une sauvegarde avant", mais faut réaliser que bon nombre d'utilisateurs ne savent pas en faire une!)... J'ai pas envie de lire un post comme ça, donc j'ai pas envie de pousser (ou qu'on pousse) les gens au-delà de leurs compétences.

Franchement, ceux qui ont l'intérêt et les connaissances nécessaires pour utiliser les nightly les ont trouvés et les utilisent déjà, si il faut les pointer... c'est probablement qu'il vaut mieux pas.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 12:55

D'accord... Et pour la X9E on fait comment alors pour le lambda ?

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 13:10

Murphy a écrit:Ca je l'ai fait. N'importe comment une fois l'EEPROM de la X9D enregistré c'est fini je reste sur Companion 2.1 et le profil de la X9E.

OK Companion 2.1 je ne comprends pas tout - Page 2 2258904616

Tu as 2.1.0 sur la radio ou le firmware livré d'origine?

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 13:31

C'est le 2.1.0 non Eu (opentx-taranis-x9e-lua-sqt5font-fr-2.1.0.bin) qui a remplacé celui d'origine. Puis j'ai flashé le module HF interne avec XJT_141016.frk a partir de la carte SD


Dernière édition par Murphy le Mar 4 Aoû 2015 - 13:58, édité 1 fois

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Mar 4 Aoû 2015 - 13:34

.


Dernière édition par dev.fred le Mar 4 Aoû 2015 - 20:06, édité 1 fois

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 13:37

Bheu j'arrive pas à reproduire une incompatibilité entre companion 2.1.0 et le FW X9E 2.1.0, ici ça marche.
Ca pourrait être une erreur d'écriture, tu "éjectes" correctement les disques après l'écriture?

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 13:47

Murphy a écrit:C'est le 2.1.0 non Eu (opentx-taranisX9e-lua-sqt5font-fr-2.1.0.bin) qui a remplacé celui d'origine. Puis j'ai flashé le module HF interne avec XJT_141016.frk a partir de la carte SD

J'ai fait une erreur en copie/coller du non de fichier. C'est bien le X9E sur la radio.

Companion 2.1 je ne comprends pas tout - Page 2 P1010118

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 13:57

Kilrah a écrit:Bheu j'arrive pas à reproduire une incompatibilité entre companion 2.1.0 et le FW X9E 2.1.0, ici ça marche.
Ca pourrait être une erreur d'écriture, tu "éjectes" correctement les disques après l'écriture?

A voir...

Ma procédure :
- J'allume la radio trims au centre + inter marche
- Je branche l'USB et radio reconnu connectée sous Windows (fenêtre ouvertes, etc...)
- J'ouvre Companion 2.1
- Je charge l'EEPROM de la radio
- Je modifie ou créé un modèle
- Je flashe l'EEPROM vers la radio et j'ai le message "Fermer".
- Je débranche l'USB et Exit.
- ... et vlan reset, calibrage des manches et j'ai rien dans les modèles sauf MODEL01.
Voilà mon problème.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 14:00

Essaie d'éjecter le disque avant de débrancher (fonction de Windows, pas de companion).

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 14:15

Je recommence.

Sur la radio...
Companion 2.1 je ne comprends pas tout - Page 2 P1010119

Je branche la X9E et charge l'EEPROM...
Companion 2.1 je ne comprends pas tout - Page 2 Eeprom10

Puis j'ouvre le Grob-120TP
Companion 2.1 je ne comprends pas tout - Page 2 Grob110

A remarquer je je n'ai pas accés aux inter et que le module HF interne n'est pas déclaré lors que l'avion est bindé sur la radio.

Voici aussi le contenu de la page FS.
Companion 2.1 je ne comprends pas tout - Page 2 Grob210

Tous les inters sont remplacé par !PV8

J'ose pas flasher la X9E car je crois que je vais encore tout perdre...

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Sacre100 Mar 4 Aoû 2015 - 14:44

Es-tu sûr que tu as le bon profil lorsque tu charges l'EEPROM. Je me dis que si tu es à ce moment en 2.0.17, Companion doit essayer de faire une conversion 2.1.0 vers 2.0.17 et que ça ce ne se passe pas bien.
Sacre100
Sacre100

Masculin Messages : 1889
Date d'inscription : 30/11/2013
Age : 64
Localisation : Blonay - Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par LapinFou Mar 4 Aoû 2015 - 14:47

Pour avoir joué avec Companion 2.0 et 2.1, on voie que l'EEPROM n'est pas la bonne si le module HF interne/externe n'est pas configuré.

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Companion 2.1 je ne comprends pas tout - Page 2 2258904616

Companion 2.1 je ne comprends pas tout - Page 2 Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15853
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 16:56

Bon c'était bien un bug qui a normalement été corrigé.
SI tu es au clair avec le sujet Wink tu peux essayer le dernier nightly de companion et confirmer que c'est OK. Pas de changement au niveau firmware.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par dev.fred Mar 4 Aoû 2015 - 17:11

C'est ce qu'on appelle l'ironie du sort  Very Happy
Quand je pense que j'ai passé 45minutes ce matin à faire une belle réponse bien documenté (j'ai réécrit 3 fois le billet) et que j'ai même poussé le vice à tester rapidement la N403 (bon d'accord sur une Taranis) tout ça pour me faire engueuler par K. et complétement ignoré par M.
Je ne serais pas une perte, mais je pense plus beaucoup contribuer sur ce forum, je suis curieux mais pas maso.

dev.fred

Masculin Messages : 758
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 17:29

Faut pas être si susceptible, même si c'est vrai qu'on peut devenir un peu durs quand on se tape un tas de reproches nous aussi Companion 2.1 je ne comprends pas tout - Page 2 2258904616

C'était simplement histoire d'expliquer le principe. Et qui s'illustre, il y a 1h on vient justement d'avoir un message de quelqu'un qui s'est plaint qu'il comprenait pas la différence si y'en avait une...

On va donc effectivement "cacher" un poil plus les nightly (il faudra télécharger un nightly manuellement avant qu'il te propose d'en récupérer d'autres) histoire de ne pas confondre les gens plus que nécessaire, et essayer de faire un petit billet qui explique ce que c'est et à quoi faire attention de manière à ce qu'on puisse simplement coller le lien quand on propose à quelqu'un de tester un nightly avec une bonne raison et quand on sait qu'on est suffisamment fiable, comme maintenant.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 18:19

Sacre100 a écrit:Es-tu sûr que tu as le bon profil lorsque tu charges l'EEPROM. Je me dis que si tu es à ce moment en 2.0.17, Companion doit essayer de faire une conversion 2.1.0 vers 2.0.17 et que ça ce ne se passe pas bien.

J'ai les deux versions de Companion installé sur le PC. La version 2.0 pour la X9D en 2.0.17 et la version 2.1 pour la X9E en 2.1.0. Pour l'instant je me sert de la seconde unique pour la X9E.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 18:20

Kilrah a écrit:Bon c'était bien un bug qui a normalement été corrigé.
SI tu es au clair avec le sujet Wink tu peux essayer le dernier nightly de companion et confirmer que c'est OK. Pas de changement au niveau firmware.

C'est pour moi que tu dis cela ? Qu'Est-ce que dois faire exactement ?

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 18:43

Télécharge ce companion:
http://downloads-21.open-tx.org/nightly/companion/companion-windows-2.1.1N403.exe

Installe et regarde bien que lors de l'installation il s'installe par-dessus le 2.1 (dans le même dossier d'installation). Teste comme normal avec ta X9E, dis-moi si c'est bon, et une fois terminé réinstalle le 2.1.0 de nouveau par-dessus.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 19:51

Premier problème la version 2.1 s'installe dans C:\Program Files (x86)\OpenTX\Companion 2.0\
J'ai corrigé l'installation pour le dossier Companion 2.1.

J'ai finalisé la mise à jour de 2.1.0 sur la Taranis-E. Puis j'ai allumé la bestiole. Tout est Ok. J'ai chargé l'EEPROM et ouvert un programme de modèle, le Grob. C'est Ok. J'ai modifié mes paramètres dans les fonctions spéciales. Puis flashé l'EEPROM sur la Taranis-E. Allumé la radio et vérifié, tout marche impec maintenant. Je n'ai plus de reset et les paramètres modifiés ont bien été mis à jour sur la radio.

Merci mais ça a été dur, dur Companion 2.1 je ne comprends pas tout - Page 2 2258904616

Ca y est, le bug vient du fait que Companion 2.1 s'installe dans le dossier du 2.0. Je viens de m'en rendre compte en cliquant sur le raccourci de ce que je croyais être le 2.1 mais qui démarre en 2.0. Je suis allé dans le dossier 2.1 et j'ai mis companion.exe sur le bureau et effectivement la fenêtre n'est pas du tout la même et j'ai bien OpenTX Companion 2.1.1N403 que je n'avais pas avant.

Je m'en suis rendu compte aussi car l'avion que j'avais sélectionné n'était plus en gras comme avant.

A voir la différence dans les FS par rapport à mon écran précédent
Companion 2.1 je ne comprends pas tout - Page 2 Grob310

Me reste plus qu'a bien le configurer s'il le faut.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Sacre100 Mar 4 Aoû 2015 - 20:33

dev.fred a écrit:C'est ce qu'on appelle l'ironie du sort  Very Happy
Quand je pense que j'ai passé 45minutes ce matin à faire une belle réponse bien documenté (j'ai réécrit 3 fois le billet) et que j'ai même poussé le vice à tester rapidement la N403 (bon d'accord sur une Taranis) tout ça pour me faire engueuler par K. et complétement ignoré par M.
Je ne serais pas une perte, mais je pense plus beaucoup contribuer sur ce forum, je suis curieux mais pas maso.

C'est dommage de te perdre, tes contributions étaient toujours utiles, mais je comprends très bien ta réaction, ça fout les boules.
Sacre100
Sacre100

Masculin Messages : 1889
Date d'inscription : 30/11/2013
Age : 64
Localisation : Blonay - Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 22:02

J'ai un autre problème que je constate depuis le début, c'est les annonces. En particulier pour le chrono moteur à rebours. Au lieu d'avoir par exemple l'annonces "quatre minutes" j'ai juste "quatre" mais pas "minutes" avec.
J'ai copié mes wav de la X9D dans system de la X9E mais ça ne change rien.

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Kilrah Mar 4 Aoû 2015 - 22:29

Les sons sont différents sur 2.1, faut charger un nouveau pack.

Kilrah

Masculin Messages : 2181
Date d'inscription : 28/01/2014
Localisation : Suisse

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Invité Mar 4 Aoû 2015 - 23:33

Kilrah a écrit:Les sons sont différents sur 2.1, faut charger un nouveau pack.

Ok, pour ceux que ça intéresse c'est ici http://voices-21.open-tx.org/opentx-taranisx9e/fr/

Charger le zip sur le PC, dézipper et copier sur la carte SD dans /SOUND/fr à la place des autres wav.

Installation faite, j'ai testé et ça marche. Par contre le son est un peu curieux. Moins clair qu'avant et avec du souffle.

Est-ce que tu a noté le problème d'installation de la version 2.1 dans le mauvais dossier comme je l'ai constaté ?

En fait je viens de tester à nouveau l'installation et cette fois le dossier de destination est bien /Companion 2.1/. Comprend pas...

Invité
Invité


Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty sons 2.1

Message par pp340 Mer 5 Aoû 2015 - 7:45

Bonjour,

Je confirme, les sons français en 2.1 sont moins bons que dans la version précédente, et certaines appellations moins "parlantes".
ex: swalert "interrupteur mal positionné" en 2.0 qui devient "alerte inter" en 2.1.
J'ai donc repiqué certains sons et appellations de la version 2.0, pour les mettre en 2.1
A+

pp340

Masculin Messages : 255
Date d'inscription : 25/07/2013
Age : 74
Localisation : Aigues Mortes

Revenir en haut Aller en bas

Companion 2.1 je ne comprends pas tout - Page 2 Empty Re: Companion 2.1 je ne comprends pas tout

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 4 Précédent  1, 2, 3, 4  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum