Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -20%
Promo sur les Baskets Nike Air Max 2090
Voir le deal
119.97 €

Problème de variable globale sur X7

+5
FLY91
CoyotteDundee
pointu
Mipel
CMa53
9 participants

Page 2 sur 2 Précédent  1, 2

Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par LapinFou Mar 13 Nov 2018 - 14:44

FLY91 a écrit:Bonjour Lapin fou

je viens de recharger complètement Companion sur le PC (désinstallation avec nettoyage des registres PC). J'ai recharger le firmware X7-2.2.2 e3ea8595, mais pas de changement.
Mon bootloader est le 2.2.2.
Je  suis loin d'être un débutant. Mon boulot est dans les systèmes complexes hard et soft j' utilise opentx depuis au moins 3 ans sur une 9E. En général sur un terrain de vol en cas de pb de programmation, c'est moi que l'on vient voir.
J'ai acheté la X7S d'occasion. Visiblement elle vient de l'étranger car j'ai du la programmer LBT EU.

Si j'appelle au secours c'est que j'ai un serieux pb. J'ai peut être raté quelque chose de simple mais quoi?

Si tu es sûr de ta procédure, essaye avec et sans l'option "noheli".
Puis vérifie que le menu est présent ou non dans ta X7.
Si tu n'arrives pas à faire cela, alors quelque chose ne va pas dans ta procédure.

En cas de doute sur l'utilisation de Companion, tu peux visionner cette vidéo: OpenTX en Français - Comment bien utiliser Companion 2.2

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Problème de variable globale sur X7 - Page 2 2258904616

Problème de variable globale sur X7 - Page 2 Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15756
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par FLY91 Jeu 15 Nov 2018 - 18:00

Bonjour

Voici les captures d'écran.:
La version
L'ecran n°4/12 (Il me manque l'ecran LUA)
et l'ecran ou je devrais trouver les GV

Sur le simu de Companion, tout est OK

J'ai chercher sur les sites US, je n'ai rien trouvé. Merci de vos aides

FLY91

Messages : 54
Date d'inscription : 30/07/2015
Localisation : Palaiseau

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par FLY91 Jeu 15 Nov 2018 - 18:01

Problème de variable globale sur X7 - Page 2 20181111
Problème de variable globale sur X7 - Page 2 20181112
Problème de variable globale sur X7 - Page 2 20181113

FLY91

Messages : 54
Date d'inscription : 30/07/2015
Localisation : Palaiseau

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par 3djc Jeu 15 Nov 2018 - 19:39

C’est un firmware avec l’option nogvar .... (comme dit depuis le départ ...)

Un firmware normal donne ca :

Problème de variable globale sur X7 - Page 2 Gvar10


3djc
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par 3djc Ven 16 Nov 2018 - 9:30

Il y a un test simple que tu peux faire, tu n'a qu'a flasher un firmware avec nogvar DECOCHE dans un autre langage (par exemple anglais si le français est installé actuellement). Si tu flash correctement, la radio devrais être en anglais (et si c'est le cas, je suis certain que les gvar y seront), mais je pense qu'elel va rester en francais parce que tu ne flash pas correctement (sinon tu aurais les gvar)

3djc
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par FLY91 Ven 16 Nov 2018 - 11:53

Bonjour

J'ai fini par trouver !!

J'ai tout d'abord récupéré une autre X7 car je commençais vraiment à douter de ma procédure. Mais là, aucun pb.
Donc pb emetteur. j'ai eu l'idée de charger le module émission non EU, puis chargement du fichier de config et là, surprise , les pages sont apparus et les globales variables étaient là.
Evidemment j'ai rechargé le fichier émission LBT EU et nickel, les pages et les variables apparaissent en fonction de mes demandes.
Je ne sais pas ce qui s'est passé lors de mon premier chargement émission mais visiblement cela ne c'est pas bien passé. Et comme à priori il n'y a pas de vérification de checksum après chargement, je ne me suis aperçu de rien.
Idem pour le fichier de config. Il ne devait rien chargé mais rien ne me le disait.

En tous cas, merci pour vos aides. J'espère que cette aventure pourra servir


FLY91

Messages : 54
Date d'inscription : 30/07/2015
Localisation : Palaiseau

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par marcsy Lun 8 Juil 2019 - 17:42

Bonjour
J’ai eu le même problème de variables globales, comme ce post m’a bien aidé…

J’ai une Taranis X9D+ depuis plusieurs années et je viens d’acheter une radio X7 chez un revendeur en France. Le firmware livré était le 2.2.2. Comme cela me convenait je ne l’ai pas changé. J’ai convertit les modèles de la X9D+ sans message critique à part ceux concernant les interrupteurs qui diffèrent entre X9D+ et X7.

J’ai fait des essais avec le simulateur opentx – pas de problème - à priori .

J’ai essayé la X7 avec une aile weasel. La course des ailerons était linéaire sur la moitié du débattement et ensuite les ailerons partaient brusquement en butée. J’ai cherché (un certain temps !) et finalement trouvé que l’exponentiel était à « -128 » car il était entré dans une variable globale et qu’il n’y avait pas de variables globales dans la page flight models….
J’ai changé le firmware en 2.2.3 avec les bonnes options. Cela fonctionne, la weasel a volé….
Merci encore pour le forum et les tutos…

marcsy

Messages : 6
Date d'inscription : 23/05/2016
Localisation : Velizy

Revenir en haut Aller en bas

Problème de variable globale sur X7 - Page 2 Empty Re: Problème de variable globale sur X7

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 2 Précédent  1, 2

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum