Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
-28%
Le deal à ne pas rater :
Brandt LVE127J – Lave-vaisselle encastrable 12 couverts – L60cm
279.99 € 390.99 €
Voir le deal

servo ne fonctionne plus sous Taranis Plus...

4 participants

Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty servo ne fonctionne plus sous Taranis Plus...

Message par DVA Ven 19 Avr 2019 - 17:36

bonsoir à tous , apres presque 1 année sans prendre en main mon emetteur " prefere" ...eh oui, renovation maison d'abord....voilà que je fais voler mon drone et là le seul servo qui me servait à ouvrir et fermer une trappe de larguage ne fonctionne plus ...il est actionné par le switch SH , j'ai voulu le passer sous SE ( 3 positions ) mais comme rien ne se passé je l'ai re-atribué au SH...quelque chose me dit que j'ai mer.....enfin pas bon quoi...! le servo est bien connecte au Pixhawk AUX OUT sur les pins 1 ( enfin les 3 plus à droite quand on regarde l'arriere du Pixhawk )... Assez novice, vous l'avez compris avec mes propos je cherche donc à ce que mon petit servo ( pas le mien ) sur le drone fonctionne de nouveau...
Merci pour votre aide et à bientôt...
PS...promis je ne resterais plus si longtemps hors connexion ...apres j'oublie trop de choses..... Laughing Laughing
Phil

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par LapinFou Dim 21 Avr 2019 - 19:23

Merci de compléter ton profil afin d'obtenir l'aide la plus pertinente possible (surtout la partie << Mettez à jour votre profils !! >>).
Les infos sont ici → << Comment bien utiliser le forum >>


En supposant que tu as une X9D (en attendant que tu mettes à jour ton profil...), as-tu modifié la config de ta radio pour dire à la radio que tu avais changé d'inter ?
Appui long sur MENU, puis plusieurs fois sur PAGE. C'est ce menu là:
servo ne fonctionne plus sous Taranis Plus...  CUcfLeI0AAAAASUVORK5CYII=

Il faut savoir que que tu peux transformer un inter 3 positions en inter 2 positions.
Par contre, l'inverse n'est pas possible ! Le hardware n'est pas prévu pour. Un inter 2 postions ne peut pas devenir un inter 3 positions !

Pour mémoire, tu peux vérifier si ta radio détecte bien les changements d'inter depuis la page d'info principale:
servo ne fonctionne plus sous Taranis Plus...  OIlAofiYAAAAAElFTkSuQmCC

Si la radio détecte correctement le changement de position de ton inter, alors le problèmes est dans ta programmation.

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. servo ne fonctionne plus sous Taranis Plus...  2258904616

servo ne fonctionne plus sous Taranis Plus...  Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 16859
Date d'inscription : 09/09/2014
Age : 49
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Pb de servo qui ne fonctionne plus...

Message par DVA Lun 22 Avr 2019 - 18:38

Bonjour à tous, je pense être à la bonne rubrique si je t'ai bien compris LapinFou...j'ai en effet rarement l'occasion d'avoir un peu de temps libre pour pianoter sur le forum et meme faire du modelisme d'où mon soucis...j'ai voulu changer de switch du SH vers un 3 positions et comme cela ne fonctionnait pas j'ai remis le SH...PB...le servo qui est sur le SH ne fonctionne plus non plus , j'ai du oublié quelque chose sur le Taranis mais quoi...? Mon servo est connecté au Pixhawk1 en port 1 du AUX OUT est tout etait ok mais j'y ai touché ....! pas cool
merci de votre aide si vous avez un peu de temps...
Bonnes Pâques à tous...
Philippe


En même temps j'en profite pour repondre ce qu'il se passe sur ma taranis Plus...( sur le SIMULATEUR de la radio )
** le bouton SH indique bien un changement d'etat fleche haut / bas selon que je le bascule vers le haut / bas ( retour bas automatique )
** mon soucis est que j'ai sur toutes les pages changé le SH ( 2 positions  sans savoir que ce n'etait pas possible) par le SA pensant pouvoir activer selon les valeurs hautes, basses et intermediaires un servo 360° pour qu'il tourne vers la droite ou la gauche ou s'arrête...
Quand j'ai vu que le servo 360° tournait sans arrêt dans un sans je n'ai pas insisté et j'ai changé de nouveau sur toutes les pages où se trouvait mon inter 2 positions par le même inter SH pensant remettre ainsi la radio comme au depart............

Et BIN NOOOON ...pas aussi simple...en fait come je l'ai dit plus haut depuis 1 année je renove ma ferme et ce n'est pas une mince affaire d'où un temps tres court pour comprendre les meandres de la Taranis ( que j' ADOOOOOOOOOOOOOOre malgré tout )...

Bon, voilà si quelqu'un à un peu de temps, merci beaucoup....
Bonne soirée à tous

[Modération par LapinFou]
Sujet déplacé dans le topic originel. @DVA: merci de répondre dans le topic que tu as déjà ouvert.

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par LapinFou Mar 23 Avr 2019 - 9:39

Si tu pouvais poster le fichier .OTX (ou .EEPPE) de ta radio cela aiderait bien pour comprendre ton problème.

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. servo ne fonctionne plus sous Taranis Plus...  2258904616

servo ne fonctionne plus sous Taranis Plus...  Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 16859
Date d'inscription : 09/09/2014
Age : 49
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 23 Avr 2019 - 15:05

Bon je m'en doutais un peu et là....personne rigole merci... :-))
apres avoir cherché je ne trouve que des " enregistré sous" qui me donnent des .bin ou .hex
et donc pas editables ( .bin )si j'ai tout suivi....
et dire que je l'ai deja fait, pas dans une autre vie mais l'annee derniere...
bref, merci de bine vouloir m'expliquer comment enregistrer en . OTX ou EEPPE

je vais le NOTER sur mon cahier SPECIAL TARANIS..........;eeeeet oui j'en suis là mais quand j'aurais termine la renovation de ma ferme se sera plus cool...
Bonne apres midi à tous


DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par LapinFou Mar 23 Avr 2019 - 15:53

Tu trouveras la réponse dans cette vidéo: Bien utiliser Companion 2.2

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. servo ne fonctionne plus sous Taranis Plus...  2258904616

servo ne fonctionne plus sous Taranis Plus...  Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 16859
Date d'inscription : 09/09/2014
Age : 49
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 23 Avr 2019 - 20:48

éh, éh,éh...pourquoi n'y ai-je pas pensé plus tôt...plus simple...pas possible...je me cantonné à des "enregistrer sous"....
bon voilà le fichier...le plus important est que je comprenne pourquoi le simple fait de changer le SH en SA ( même si cela n'est pas possible ) je n'ai pas pu retrouver le bon fonctionnement de SH....!

Bonne soirée et bons vols à tous
Fichiers joints
servo ne fonctionne plus sous Taranis Plus...  Attachment
Ma Radio.zip Vous n'avez pas la permission de télécharger les fichiers joints.(8 Ko) Téléchargé 9 fois

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par Ledabe Lun 29 Avr 2019 - 18:44

Bonjour,

Déjà SH est sur la voie 9. Cela veux dire que tu as un récepteur 9 voies ?

Je crois avoir trouvé. Tu as déclaré 8 voies dans la configuration du modèle. Il faudrait mettre "Nombre de voies : 9" ou plus.
Ledabe
Ledabe

Masculin Messages : 749
Date d'inscription : 16/09/2018
Age : 41
Localisation : Razimont

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par LapinFou Mar 30 Avr 2019 - 9:33

Ledabe a raison. Je viens de regarder ta config et tu as fait le bind en mode D16 "8 VOIES".
Donc seul les 8 premières voies sont transmises.
Il faut que tu refasses le bind en mode D16 "16 VOIES".

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. servo ne fonctionne plus sous Taranis Plus...  2258904616

servo ne fonctionne plus sous Taranis Plus...  Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 16859
Date d'inscription : 09/09/2014
Age : 49
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 30 Avr 2019 - 16:55

AAAAAHH ben flute alors...mais pourquoi le servo fonctionnait-il avant que je change le SH en SA...? a moins que ...j'ai utilisé un recepteur Delta 8 pour connecter à un arduino uno et faire des essaies, j'ai dû binder ma Taranis en 8 voies et lorsque je l'ai bindée à nouveau pour mon recepteur X8r et changer mon inter donc de SH à SA je suis passé en D16 mais je n'ai pas pensé certainement au mode 16 voies...cela serait-il possible comme explication....?
En tous cas merci je vais regarder la Taranis...je vous tiens informés...
Bons vols

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 30 Avr 2019 - 18:47

Bon resultats des essaies....sur open TX je change " nombre de voies "....16
mais je n'ai rien retransmis à ma radio via Open TX, je voudrais eviter de faire + de conn...

Sur ma radio, j'ai changé...ds le menu " Configurations"
...Mode D16 ( rien changé )
.....Plage de Canaux...j'avais CH1 - 8
...j'ai essayé...CH1 - 16 puis Bind avec 2 jumpers sur les CH1 à 2 et CH 3 à 4 (comme decris ds la notice Mode 4(D16), canaux de sorties CH9-CH16, jumpers before bind CH1 et 2, CH 3et 4 )
...puis Bind...j'ai ensuite retirer les jumpers , debranchée/rebranchée la batterie, la lampe reste verte fixe sur l' X8r donc je pense avoir bindé correctement ...
...la mise en route des moteurs apres la sequence du Pixhawk fonctionne, ainsi que les modes de vols qui 'bipent' qd je change avec les inters...mais tojours pas de servo qui fonctionne ( sur AUX Out 1 comme branché avant ).....
le plus ennuyeux est de ne pas comprendre le cheminement qui fait que le servo ne veut rien "savoir"...
j'y retourne...merci à plus

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 30 Avr 2019 - 18:49

j'oubliais je passe en Sbus ( comme avant les pb du servo ) du X8r au Pixhawk...
Bonne soirée à tous

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par LapinFou Mar 30 Avr 2019 - 22:59

Vu comment tu as fait ton bind (mode 4), la sortie 1 de ton X8R correspond à la voie 9.
Donc si tu branches ton servo dessus, cela devrait fonctionner.

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. servo ne fonctionne plus sous Taranis Plus...  2258904616

servo ne fonctionne plus sous Taranis Plus...  Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 16859
Date d'inscription : 09/09/2014
Age : 49
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mar 30 Avr 2019 - 23:32

aaaaah je comprends ...donc le servo fonctionnerait sur la sortie 1 ( voie 9 ) sans passer par la sortie AUX OUT du Pixhawk...!
et les sorties du X8R correspondent à :
sortie2 --- voie10
sortie3 --- voie 11
sortie4 --- voie 12
sortie5 --- voie 13
sortie6 --- voie14
sortie7 --- voie15
et...sortie8 --- voie16
donc les 16 voies passent par le Sbus mais 8 disponibles (1 à 8 ) en connexions et programmation via le Sbus et les 8 autres ( 9 à 16 ) en connexions directes sur les sorties du recepteur ( notées par le fabricant 1 à 8 )
de plus le servo sera alimenté par le "+" et "-" directement par le recepteur...
ai-je tout juste en esperant être clair ds mes explications...?

d'où une question...je souhaite placé un servo à 360° via un arduino uno, dois-je connecter le signal depuis la même voie ( 9 etant donc la 1 physiquement sur le recepteur ) puis connecter sur une broche de l'arduino ( exemple le pin2 ) et programmer l'arduino en indiquant qu'en fonction de l'impulsion ( exemple 980<1450>1900 ) l'inter ( exemple le slider gauche ) doit donner "tourne à gauche " ou "tourne à droite"...bien sûr communication entre le recepteur et l'arduino 115200bauds...quant au "+" et "-" ils seraient pris sur l'arduino pour le GND et sur le pololu ( qui me donne du 7.2volts ) pour le "+".....
peut-être dois-je connecté plutôt mon signal du servo 360 à la broche RXD de l'arduino...?

voilà, voilà, je pense avoir compris pour les voies et je me creuse la cervelle pour l'arduino avec lequel je debute....mais vraiment interressant...

Bonne soirée à tous ...demain je lance les essaies....

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par gravel Mer 1 Mai 2019 - 10:03

Autre solution tu prends un servo et tu rajoutes une résistance en série sur les deux pattes extérieures du potentiomètre ce qui augmente la course et permet la commande directe via la radio sans Arduino.

gravel

Masculin Messages : 762
Date d'inscription : 22/10/2015
Age : 68
Localisation : Nantes

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par DVA Mer 1 Mai 2019 - 20:04

bonsoir et merci le servo fonctionne de nouveau en connectant sur la sortie 1 du X8R soit ma voie 9 ...donc je pourrais connecter 7 autres servos sur les 7 autres sorties en assignant 7 voies differentes ( dans l'absolu...) bref, je pense enfin saisir le sens du mode 4 et du Sbus...
Pour repondre à gravel, effectivement je pourrais passer par un servo mais j'aime bien l'arduino et surtout le moteur MG995 transformé en 360° doit tourner ds le sens des aiguilles d'une montre ou ds l'inverse avec un delai en millisecondes et ceux sont des end-stop qui permettent de changer de sens de rotation...je ne suis pas certain que cela soit possible avec un servo...? mais je me trompe peut-être
en tous cas, si tu penses que je dois connecter le signal du recepteur sur la borne RXD de l'arduino...?
Bon vols à tous

DVA

Masculin Messages : 52
Date d'inscription : 09/06/2016
Age : 59
Localisation : Bazoges en Pareds

Revenir en haut Aller en bas

servo ne fonctionne plus sous Taranis Plus...  Empty Re: servo ne fonctionne plus sous Taranis Plus...

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum