Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -37%
Ecran PC Gamer Incurvé – ACER – ...
Voir le deal
179.99 €

Problème de widgets suite à la migration 2.2.4 à 2.3.1

3 participants

Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Lun 4 Nov 2019 - 17:12

Bonjour,

J'ai certainement du louper un épisode ou deux mais, suite à la migration de OpenTX 2.2.4 à 2.3.1, j'ai maintenant une belle salade au niveau des widgets sur ma Horus X12S (ce ne sont plus les mêmes intitulés qui sont affichés (ex SWR au lieu de RSSI, VG5 au lieu de Bat, ...) en ce pour tous les modèles. Tout c'est déroulé correctement pendant la migration et, à part les widgets, tout me paraît correct (commandes, télémétrie, ...).

Les widgets de type "script" sont enregistrés sur la SD (/Widgets/Name/main.lua) mais je ne sais pas où sont les autres ?

Est-ce que quelqu'un pourrait me mettre sur la piste ?

Un grand merci par avance
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par 3djc Lun 4 Nov 2019 - 19:39

Oui, les sensors ne sont plus les même, il faut réaffecter les bons sensors aux widgets
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par Mipel Lun 4 Nov 2019 - 20:13

Peux-tu lister ceux qui sont concernés, ça intéresse aussi du coup !

_________________
Electrique :
Avions: extra 330sc, clik R2 + mini-polyclub en indoor
Planeurs: Gem, Serenity et Typhoon
Hélicos: Trex 250-450-550
Drones: Wizard X220, Aurora 90 vol à vue+fpv
Thermique :
Extra 300 78'' avec DLE 35RA


Besoin d'infos ? https://opentx-doc.fr/ (co-admin du site avec LapinFou)
Mipel
Mipel
Modérateur

Masculin Messages : 2896
Date d'inscription : 08/06/2017
Age : 64
Localisation : 85 Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Lun 4 Nov 2019 - 20:55

@3djc : ok, j'en prend note. Ça va me faire un bon petit travail car j'ai à peu près une vingtaine de modèles avec 8 valeurs par modèle. De plus, je n'ai pas de sauvegarde pour me facilité la tâche.

J'abuse peut-être ... j'avais l'habitude d'entendre le nom de mon modèle ainsi que la position des switchs "surveillés" lors de la mise en tension de l'émetteur. Ça ne fonctionne plus comme avant. Lors de la mise en tension de l'émetteur : reste muet; lors d'un changement de modèle : nom du modèle + switchs "surveillés" (ok, comme avant). Ai-je loupé quelque-chose ?
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Lun 4 Nov 2019 - 23:23

@Mipel : en fait il faut tous les modifier. J'en ai terminé avec la reconstruction mais ... je dois repasser par la case : supprimer tous les capteurs, découvrir tous les capteurs, reporter la nouvelle configuration au niveau de la télémétrie ainsi que des fonctions logiques, modifier les widgets pour enfin arriver à introduire les variables correctement pour les scripts de type BattCheck, Timer, ...
Enfin si quelqu'un a plus court, je suis preneur.

Autre "soucis" encore incompris : j'avais l'habitude d'entendre le nom de mon modèle ainsi que la position des switchs "surveillés" lors de la mise en tension de l'émetteur. Ça ne fonctionne plus comme avant. Lors de la mise en tension de l'émetteur : reste muet; lors d'un changement de modèle : nom du modèle + switchs "surveillés" (ok, comme avant). Ai-je loupé quelque-chose ?
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 0:39

En ce qui concerne les annonces, tout est correct au niveau du simulateur.
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 9:34

En ce qui concerne le problème lié aux variables introduites aux scripts (cas d'un capteur unique (FLVSS)), j'ai trouvé plus simple :

 - effacer uniquement le capteur
 - faire une redécouverte
 - renommer le nom (Cells -> xxx) comme il était avant
 - mettre à jour le widget (décallage +2 pour moi)

Je m'étais aperçu que le capteur original était vu faussement par OpenTX (Unité : tan, Précision, ...)

Je devrai également vraisemblablement modifier les autres modèles "multi capteurs) qui ont des FLVSS.
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par Mipel Mar 5 Nov 2019 - 10:06

j'avais l'habitude d'entendre le nom de mon modèle ainsi que la position des switchs "surveillés" lors de la mise en tension de l'émetteur.
Avec des fonctions spéciales je suppose. Pourrais-tu partager ton fichier de modèles pour que je puisse regarder ça ?

Entendre les switchs surveillés, ça donne l'annonce "Interrupteur mal positionné" c'est ça ? correspond au fichier swalert.wav situé dans SOUNDS/fr/SYSTEM -> à vérifier si bien présent et "audible"

et pour le nom du modèle, tu dois avoir une FS - Un - Jouer fich - nom_du_modele ?
ton fichier modèle est valide et au bon endroit sur la carte sd ?


Liste des widgets:
j'ai testé Battcheck en 2.3.1, capteur FLVSS correctement détecté, pas de soucis rencontrés.
Donc dis moi lesquels tu utilises.

_________________
Electrique :
Avions: extra 330sc, clik R2 + mini-polyclub en indoor
Planeurs: Gem, Serenity et Typhoon
Hélicos: Trex 250-450-550
Drones: Wizard X220, Aurora 90 vol à vue+fpv
Thermique :
Extra 300 78'' avec DLE 35RA


Besoin d'infos ? https://opentx-doc.fr/ (co-admin du site avec LapinFou)
Mipel
Mipel
Modérateur

Masculin Messages : 2896
Date d'inscription : 08/06/2017
Age : 64
Localisation : 85 Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par 3djc Mar 5 Nov 2019 - 11:50

Il me semble avoir fixé ce soucis, faudrais tester une nightly juste pour voir
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 14:20

@Mipel :

Pas des fonctions spéciales, juste Battcheck légèrement modifié (tourne bien jusqu'à l'upgrade à 2.3.1). J'ai maintenant corrigé les problèmes des capteurs et tout est rentré dans l'ordre (((Je m'étais aperçu que le capteur original était vu faussement par OpenTX (Unité : tan, Précision, ...))))

Oui, nom du modèle et position (verbale) des switchs "surveillés" (cochés dans le premier menu des modèles). Ça a toujours bien fonctionné jusqu'au dernier update. Ça fonctionne correctement quand je change de modèle. Aucun problème en ce qui concerne les switchs mal positionnés (annonce et réaction correcte)

@3djc : le décalage des capteurs ou les annonces ?
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par 3djc Mar 5 Nov 2019 - 16:16

Les annonces
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 18:14

@3djc : tu veux que je teste le dernier nightly ?

La procédure de test :

 - sauvegarde
 - mise à jour via companion 2.3.1 en cochant "candidate test" (V2N33)
 - mise à jour radio éteinte
 - test
 - mise à jour via companion 2.3.1 en cochant "Officiel (stable)"
 - retest

Je ne modifie rien sur la carte SD

Peux-tu me confirmer que je retrouverai au départ ?
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par Mipel Mar 5 Nov 2019 - 18:55

@filduch
position (verbale) des switchs "surveillés" (cochés dans le premier menu des modèles).

Peux-tu préciser ce que tu veux dire là ? tu as une annonce pour chaque inter mal positionné ou seulement l'annonce globale citée dans mon post précédent ?

utilises-tu des fonctions globales qui pourraient interférer avec les fonctions spéciales ?

_________________
Electrique :
Avions: extra 330sc, clik R2 + mini-polyclub en indoor
Planeurs: Gem, Serenity et Typhoon
Hélicos: Trex 250-450-550
Drones: Wizard X220, Aurora 90 vol à vue+fpv
Thermique :
Extra 300 78'' avec DLE 35RA


Besoin d'infos ? https://opentx-doc.fr/ (co-admin du site avec LapinFou)
Mipel
Mipel
Modérateur

Masculin Messages : 2896
Date d'inscription : 08/06/2017
Age : 64
Localisation : 85 Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par 3djc Mar 5 Nov 2019 - 21:59

filduch a écrit:@3djc : tu veux que je teste le dernier nightly ?

La procédure de test :

 - sauvegarde
 - mise à jour via companion 2.3.1 en cochant "candidate test" (V2N33)
 - mise à jour radio éteinte
 - test
 - mise à jour via companion 2.3.1 en cochant "Officiel (stable)"
 - retest

Je ne modifie rien sur la carte SD

Peux-tu me confirmer que je retrouverai au départ ?

Pas besoin de mettre à jours radio éteinte, mais il me semble qu’il faut être en branche nightlies, je sais plus comment ça a été traduit. Et oui, tant que l’on reste dans la même version majeure (2.3.x) ont peut changer de version à volonté
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 22:31

Aucune fonction globale qui interfère avec les spéciales. J'en utilise qu'une : FG1, Action : Volume, Paramètre : Vol, Actif : on

Ce que je veux dire c'est quand un modèle est activé soit par la mise en tension de l'émetteur ou soit lors d'un changement de modèle via OpenTX, le nom du modèle ainsi que la valeur de tous les switchs cachés dans le menu "Configuration" sont annoncés. Tout a fonctionné depuis bien longtemps et je n'ai rien modifié. Suite à la migration à OpenTX 2.3.1, seules les annonces sont émissent quand je change de modèle (plus d'annonces lors de la mise en tension de l'émetteur (seule annonce : bienvenue dans openTX)
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Mar 5 Nov 2019 - 22:32

@3djc : je m'en occupe dès que possible
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par filduch Ven 8 Nov 2019 - 10:54

@3djc : le problème a été corrigé sur la version 3.2 nightly 2.3.2N36 Il ne me reste plus qu'à attendre la version 2.3.2 officielle.

Procédure effectuée :

 - téléchargement de la version nightly de Companion et installation (Windows 10) sur une arborescence différente de la 2.3
 - démarrage de Companion nightly, - modification de Paramètres - Editer les paramètres - Paramètre de l'application -
   Canal de version : Nightly (instable)
 - téléchargement de OpenTX par Companion - "Télécharger"
 - Émetteur éteint connecté USB sur le PC et transfert de OpenTX - "Transférer le firmware à la radio"
 - Test puis retour à l'originale sans perte

Merci à toi pour tout le temps que tu investis à faire évoluer OpenTX
filduch
filduch

Masculin Messages : 1419
Date d'inscription : 01/01/2016
Age : 62
Localisation : Suisse - Versoix Model Club

Revenir en haut Aller en bas

Problème de widgets suite à la migration 2.2.4 à 2.3.1 Empty Re: Problème de widgets suite à la migration 2.2.4 à 2.3.1

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum