Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.

Plus de sons sur le simulateur de Companion

Aller en bas

Plus de sons sur le simulateur de Companion Empty Plus de sons sur le simulateur de Companion

Message par PHILFOUL77 Sam 28 Mai 2022 - 19:36

Bonjour à tous,

Je souhaiterais savoir si d'autre "forumers" utilisant MAC OS rencontrent le même souci que moi.
Depuis le passage sous Companion 2.3.14 mes alertes vocales ne fonctionnent plus sur le simulateur de Companion alors qu'elles sont toujours opérationnelles dans les fonctions spéciales, que tout est nickel quand j'effectue le transfert des paramètres sur ma radio TX16S et que je ne me souviens pas avoir introduit d'importants changements à l'époque.

Companion ne me fournit depuis aucun message mais rien ne se passe à l'activation du simulateur (tout fonctionne sauf les voies : dommage pour la vérification du bon fonctionnement des interrupteurs).
Selon mes souvenirs ce dysfonctionnement est apparu au moment du passage à la version 2.3.14 mais à cette époque APPLE fournissait aussi des mises à jours de ses versions 2.13 (Big Sur) que j'effectuais.
La gêne n'étant pas très importante je me suis dit attendons une nouvelle version de Companion qui règlera probablement ce désagrément.
Bang la dèche, avec la version 2.3.15 c'est pareil : toujours pas de sons.

Ces jours-ci APPLE ayant largement dégrossi la version majeure de son MAC OS Monterey (2.14) je me suis décidé à faire la migration sur mon IMAC de bureau (Retina, I5, 27 pouces - 2017) : espoir déçu et aucune amélioration du fonctionnement du simulateur !
A la lecture des fichiers de logs/Debug il semble que le simulateur, qui crée des "path" temporaires, ne trouve pas un sous-dossier sons de même nom que le modèle simulé sous le dossier des sons fr (logique selon moi, ce type de dossier n'ayant jamais existé sur l'arborescence de la carte SD mais erreur warning dans le log). De même dans certains de ces fichiers (pas toujours...) je comprends que le simulateur est en dépassement de capacité mémoire ou "overflow" (de 150 à 300 octets environ) mais je ne connais rien à la programmation et au développement du simulateur.

A toutes fins utiles je fournis en PJ à LapinFou et aux autres experts de ce forum une archive comprenant mon fichier OTX ainsi que les deux fichiers de logs/debug de Companion et du firmware. L'archive permettra peut-être a minima de vérifier le bon fonctionnement de mon fichier OTX sous Windows (le plus complet "vocalement" étant le modèle de planeur Phoenix_2400).

Avec tous mes remerciements anticipés pour votre aide.
Cldt,
Philippe

PHILFOUL77

Masculin Messages : 3
Date d'inscription : 28/05/2022
Age : 69
Localisation : Val d'Oise

Revenir en haut Aller en bas

Plus de sons sur le simulateur de Companion Empty Plus de sons sur le simulateur de companion (Bis)

Message par PHILFOUL77 Sam 28 Mai 2022 - 19:55

Suis pas certain d'avoir joint correctement l'archive...
Fichiers joints
Plus de sons sur le simulateur de Companion Attachment
OTX+2logs.zip Fichier OTX plus deux fichier de Logs pour déboggageVous n'avez pas la permission de télécharger les fichiers joints.(10 Ko) Téléchargé 1 fois

PHILFOUL77

Masculin Messages : 3
Date d'inscription : 28/05/2022
Age : 69
Localisation : Val d'Oise

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum