Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment : -40%
-40% sur le Bureau gaming Alpha Omega Players
Voir le deal
89.99 €

Probleme de versions et de mises à jour

5 participants

Aller en bas

Probleme de versions et de mises à jour Empty Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 9:41

Bonjour
Après de nombreuses aventures, j'ai obtenu que mon X9D+2019 soit fonctionnel avec OpenTX 2.3 RC5
J'ai flashé le module interne du TX vers LBT, ça s'est déroulé sans problèmes.
Le souci est que ça ne bind pas avec mes X8R
Les X8R sont en EU LBT
ça ne bind toujours pas.

Ma 1° question est donc: quelle version de SDCard prendre avec le OpenTX2.3RC5 pour une XD9+2019 ? J'ai essayé de télécharger celle plus récente sur le site de OpenTX/downloads: elle est vide !
la Sdcard que j'avais est celle indiquée par LapinF, elle est complète mais elle ne binde pas ...

Pas de problème pour reven,ir à celle de LapinF

2° question : y'a t'il un moyen de vérifier quelle version (LBT ou FCC) est effectivement utilisée par le TX ?

Merci
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par gravel Ven 27 Sep 2019 - 9:58

1, tu reprends la carte du Lapin si tu veux obtenir les sons en Français et tout ce qu'il faut, y compris les derniers firmwares pour flasher ton module interne.

2, non pas moyen de savoir.

Tu as deux émetteurs, peux-tu binder tes récepteurs avec la X7 ?

essayes de reflasher le module interne. Le bon fichier c'est XJT_LBT_2017-03-17.frk il est sur la carte du Lapin.

gravel

Masculin Messages : 762
Date d'inscription : 22/10/2015
Age : 66
Localisation : Nantes

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 10:09

gravel a écrit:essayes de reflasher le module interne. Le bon fichier c'est XJT_LBT_2017-03-17.frk il est sur la carte du Lapin.
Noooonnn !!
Probleme de versions et de mises à jour 2258904616
La X9D+ 2019 utiliser un module interne ISRM (avec le nouveau protocole ACCESS), pas XJT.

Pour flasher le module interne, il faut faire 2 choses:
1. Utiliser le fichier ISRM_X9DP_v1.1.3.frk dispo dans le dossier \FIRMWARE\ACCESS\ISRM
2. Exécuter le script LUA isrm_mode.lua disponible dans ce même dossier \FIRMWARE\ACCESS\ISRM. Ce script te permettre de mettre ta radio en mode LBT afin de respecter la législation Française.

Et voilà !
albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par gravel Ven 27 Sep 2019 - 10:12

Oups Embarassed désolé, j'avais regardé dans la colonne de droite X9D+

Le albino a toujours raison Very Happy

gravel

Masculin Messages : 762
Date d'inscription : 22/10/2015
Age : 66
Localisation : Nantes

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par CoyotteDundee Ven 27 Sep 2019 - 10:12

Bonjour,

le bind entre la radio et un récepteur n'a rien à voir avec le contenu de la SDCard. Au pire tu auras un message te signalant que le contenu de la carte ne correspond pas à la version du logiciel installé dans la radio.
De toute manière, si tu utilises les packs du Lapin Fou, il n'y a aucun souci car ils sont à jour.

SI tu as un problème de bind, c'est que
- Soit tu appliques mal la procédure de bind
- Soit il existe une inadéquation entre le logiciel XJT de ta radio et celui des récepteurs.
Si les récepteurs se bindaient avant la mise à jour de la radio ET que tu n'as pas reflashé le module XJT, il n'y a aucune raison que cela ne fonctionne pas. (Sauf grosse, grosse douille dans la RC5 mais je serais vraiment surpris)

La X9d+ 2019 peut binder en ACCST et en ACCESS selon la doc. Est-ce que tu n'es pas en train d'essayer de binder en ACCESS des récepteurs ACCST ?

Coyotte

_________________

... the alien anthropologists admitted they were still perplexed.
But on eliminating every other reason for our sad demise, they logged the only explanation left :
This species has amused itself to death...
                                                                                                                                    (R. Waters)

Pas de support par MP ! Nous sommes sur un forum pour échanger publiquement.
CoyotteDundee
CoyotteDundee
Modérateur

Masculin Messages : 5356
Date d'inscription : 03/03/2014
Age : 57
Localisation : Montegnée (Liège)

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 10:41

Merci de vos réponses
Non, j'essaye de flasher en ACCST et pas en Access car je n'ai pas les RX qui vont avec.
Je suis entrain de suivre ton idée, Lapin, mais cela va me mettre en Access.
OK pour la passer en LBT avec le LUA mais ça va refuser mes X8R ...
qui par ailleurs bindent et fonctionnent parfaitement en ACCST avec ma QX7
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 10:55

Les radios avec le module ISRM supporte le mode ACCSST D16 et le nouveau protocole ACCESS.
Donc, la manip que je t'ai expliqué est la seule que tu dois faire sur une X9D+ 2019 (d'ailleurs pense à mettre à jour ton profil, sinon cela va être source de confusion)

Après, c'est au moment du bind que tu choisies si ton RX est de type ACCSST ou ACCESS.
Probleme de versions et de mises à jour Gcq+RV+MaRgAAAABJRU5ErkJggg==

Probleme de versions et de mises à jour 7iiqoVwAAAAASUVORK5CYII=

albino
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 11:10

Lapin, elle se met bien en Access mais les X8R ne la reconnaissent pas, normal ils sont en ACCST.

J'ai reflashé en ACCST LBT et cette fois ci ça marche !!!

J'ai simplement mis le X8R en NUMERO 3 au lieu de 1. J'avais essayé 2 mais ça ne marchait pas non plus.

Lapin, tu avais écrit qqchose au sujet de ces numéros de RX, c'est donc encore valable avec les versions livrées tout dernièrement, le bug n'est pas réparé.

Merci à tous et à Lapin
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 11:39

Visiblement on ne se comprend pas.

Tu as bien une X9D+ 2019 ?

Si oui, alors tu flashes le module interne:
1. Utiliser le fichier ISRM_X9DP_v1.1.3.frk dispo dans le dossier \FIRMWARE\ACCESS\ISRM
2. Exécuter le script LUA isrm_mode.lua disponible dans ce même dossier \FIRMWARE\ACCESS\ISRM. Ce script te permettre de mettre ta radio en mode LBT afin de respecter la législation Française.

Tu flashes ton RX X8R:
- Utiliser le fichier X6R-X8R_LBT_2017-02-10.frk dispo dans le dossier \FIRMWARE\ACCST\LBT\X series

Tu fais le bind depuis ta X9D+ 2019 avec ton X8R en choisissant ce mode:
Probleme de versions et de mises à jour Gcq+RV+MaRgAAAABJRU5ErkJggg==

Que veux-tu dire par, "J'ai reflashé en ACCST LBT et cette fois ci ça marche !!!" ?? Tu parles du RX ou de la radio ?

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 11:59

J'ai bien une X9D+2019 et j'ai fait toute la manoeuvre jusqu'au LUA, sur le TX. Le TX est donc en ACCESS LBT.

Le RX est bien flashé avec le fichier que tu indiques, configuré en ACCST D16

Pas de Bind.

Je reflashe le TX en ACCST LBT

Pas de bind avec le RX en ACCST D16 configuré en numéro 1 ou 2 dans l'écran de 'Configuration Modèle'

Je configure alors le RX en déclarant le RX comme numéro 3

Là ça Bind.
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 12:05

Guillaume60 a écrit:Je reflashe le TX en ACCST LBT

Tu flashes avec quel firmware ???

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 12:34

Le TX avec la dernière version 2.3RC5, configuré et téléchargé avec Companion en 'eu' etc.
le RX avec ton fichier X6R-X8R_LBT_2017-02-10.frk
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 12:39

Le firmware du module interne n'a rien à voir avec la version d'OpenTX.

Ne pas confondre firmware de la carte RF de la radio et le firmware OpenTX. Ce sont 2 choses qui fonctionnent ensemble, mais qui sont différentes.
- Le module RF (RF = Radio Fréquence) interne, c'est la partie qui établit le lien 2.4GHz entre le TX (la Taranis) et le récepteur (ce qui est dans le modèle volant et qui contrôle les servos). C'est de cela que l'on parle dans cet article. Cela concerne aussi les modules XJT FrSky externe.
- OpenTX, c'est l'OS du TX (la Taranis). C'est la partie qui permet de tout gérer. C'est le chef d'orchestre qui vérifie la positions des manches, des boutons, le retour de télémétrie, qui contrôle le module RF, l'écran, le vibreur, etc..
Chacun a sa propre version de firmware, et même s'ils travaillent en symbiose, la mise à jour de l'un n’impacte pas le fonctionnement de l'autre.

Donc, je ne comprends toujours pas ce que tu fais... J'essaye de t'aider, mais on ne parle pas le même langage.. Wink Probleme de versions et de mises à jour 2258904616

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 14:04

OK
en effet ils sont différents. Désolé.

Donc je flashe le module à partir du contenu de la carte SD que tu as mis à disposition, en ACCST.
le RX aussi à partir de la carte SD

Ceci dit, la seule différence entre échac du Bind et réussite du Bind a été de mettre un numéro de RX 3 au lieu de 1 ou 2. Cela semble indiquer un souci au niveau de OpenTX puisque cela se détermine dans la config du modèle.
Je n'ai rien changé d'autre.

Merci
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 14:48

Guillaume60 a écrit:Donc je flashe le module à partir du contenu de la carte SD que tu as mis à disposition, en ACCST.
Quel dossier et quel fichier utilises-tu ??

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Ven 27 Sep 2019 - 19:04

pour le module HF:
Je pars de la carte SD:
Firmware =>ACCST=>LBT=>XJT =>XJT LBT 2017. 03 17.frk
commande "flasher le module interne"
est ce que ça t'éclaire ?
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 19:14

Oui, là, c'est clair.
Probleme de versions et de mises à jour 2258904616

Je ne comprend pas comment cela peut fonctionner...
Si ta X9D+ est bien un version 2019, seul le firmware IRM devrait fonctionner...

Je ne sais pas quoi te dire.

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par EPARDELIERE Ven 27 Sep 2019 - 19:45

Bonjour,
Tu ne sembles pas utiliser la bonne procédure pour optimiser ton module HF.
Sur la carte de notre Lapin prendre :
ACCESS
ISRM
Puis pour finir ISRM X9DP.
Seulement après exécuter le script lua, pour basculer ta radio en ACCST.
ENSUITE TU NE TOUCHES PLUS A RIEN SIMPLEMENT RECHERCHES COMMENT, METTRE A JOUR TES RX AVANT DE FAIRE LE BIND.

EPARDELIERE

Masculin Messages : 131
Date d'inscription : 19/02/2018
Age : 67
Localisation : CHARENTE CONFOLENS

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Ven 27 Sep 2019 - 19:52

EPARDELIERE a écrit:Seulement après exécuter le script lua, pour basculer ta radio en ACCST.
Le script ne sert pas à basculer en mode ACCST. Le script sert à commuter le module ISRM soit en FCC, soit en LBT (et cela s'appliquera au mode ACCESS et au mode ACCST)

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Sam 28 Sep 2019 - 9:13

Bonjour à tous deux
J'ai fait la manoeuvre de mettre en ACCESS avec le lua pour finir. J'ai ensuite remis en ACCST pour que la HF soit acceptée par mes RX qui sont tous en ACCST.
J'ai aussi mis à jour le RX avec le bon FW qui se trouve sur la carte SD.
Sur ce RX ça marche et ça semble tenir.

Lapin, le mode ACCESS donne plusieurs autres paramètres jusqu'alors inconnus: une Identité entre autres. Prévois tu une petite explication ad hoc ?
Merci pour ta compétence et ta disponibilité.
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par LapinFou Sam 28 Sep 2019 - 13:29

On est bien d'accord que tu as mis à jour ton module RF interne avec un firmware ISRM ?
Oui/Non ?

Le script LUA permet de choisir si ta radio est en mode FCC ou LBT.
Le protocole ACCESS (comme le ACCST) doit respecter une norme (FCC ou LBT).
La différence avec l'ancien module XJT, c'est que le choix ne se fait pas au moment du flashage. Le nouveau module RF interne ISRM a suffisamment de mémoire pour stocker les 2 versions. C'est pour cela qu'il y a un unique firmware (comme pour les RXs).

Lorsque ta radio 2019 est flashée avec le firmware ISRM, tu peux choisir dans le menu "module RF interne" ACCESS ou ACCST D16 ou ACCST LR12.
Voir mes capture d'écrans dans mon précédent post: https://frskytaranis.forumactif.org/t9130-probleme-de-versions-et-de-mises-a-jour#99803

Concernant ta dernière question un article est prévu par Ceeb182. Mais je n'ai aucune date à te donner. Il est comme tout le monde: il a plein de choses à faire. Probleme de versions et de mises à jour 2258904616

albino

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Probleme de versions et de mises à jour 2258904616

Probleme de versions et de mises à jour Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15862
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Sam 28 Sep 2019 - 18:51

Cher Lapin
Oui je suis passé par un flashage en ISRM selon tes indications. Le lua l'a mis en LBT.

Ceci posé, le choix existe dans la carte SD pour flasher en ACCST ou en ACCESS.
A ce stade je pense être en ISRM avec le choix ACCST comme tu le dis. Mais je ne sais pas le vérifier.
Du moment que ça marche, c'est que la RF sort en ACCST. Je le vérifierai quand je vais acheter un RX qui sera en ACCESS seul.

Encore merci
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Guillaume60 Sam 28 Sep 2019 - 18:53

Dernière chose: comment expliquer que ça ne fonctionne pas si je laisse le numero de RX à 1 et ça fonctionne si je le mets à 3 ?
Cordialement
Guillaume60
Guillaume60

Masculin Messages : 136
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

Probleme de versions et de mises à jour Empty Re: Probleme de versions et de mises à jour

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum