Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
-54%
Le deal à ne pas rater :
Smartphone 6.5″ OPPO Reno4 Pro 5G 256Go Noir
182 € 400 €
Voir le deal

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

2 participants

Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Jeep1656 Ven 10 Nov 2023 - 17:25

Bonjour,
COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES 2247334666
Je crains d'avoir fait une boulette en mettant une radio X9D de V2.3.11 à V2.3.15:
C'est une radio que j'avais programmé en 2021, avec Companion, et que j'ai récupéré récemment pour un "petit ménage" dans les modèles ( modifs intempestives, ajout de modèles, retrait d'autres...)bref!
La personne n'est pas très à l'aise en prog OpenTX et encore moins avec Companion....
Ayant œuvré avec application dans tout ses modèles, il m'a pris la bonne idée de lui mettre à jour le firmware de la radio (ainsi que le bootloader pour Companion 2.3.15).
Tout avait l'air parfait au niveau émetteur je lui ai donc rendu sa radio , pour reprendre éventuellement les réglages sur les modèles.
Malheureusement, dès le premier modèle, il n'y a plus de liaison avec le RX.
Précisions: la version précédente était en Non-EU, ce que j'avais oublié, j'ai flashé le TX en 2.3.15 EU. les récepteurs sont restés dans une version NON-EU.
Il semble que certains modèles soient équipés de récepteurs "équivalents compatibles" non FRSky, et fonctionnaient auparavant.(ex AC410)

J'ai donc 2 causes probables, et besoin de votre aide pour la solution la plus simple (et la plus sure)
-soit cela vient du fait que les RX ne sont plus dans une version assez récente (ce qui me parait improbable, vu que le protocole ACCST n'a pas changé)
-soit cela est lié au paramètre EU que j'ai coché dans le firmware de la X9D au moment de la mise à jour récente.
Puis-je simplement reflasher la radio avec le paramètre EU coché?
Ou dois-je plutôt revenir à une version plus ancienne du firmware radio? En espérant ne pas devoir reculer aussi sur Companion 2.3.11 (normalement non?)

J'ai bien relu le document "Ce qu'il faut savoir", mais un petit coup de pouce me serait utile pour me rafraichir la mémoire.scratch
j'attends votre réponse avant de toucher quoique ce soit...
merci d'avance
Jeep1656
Jeep1656

Masculin Messages : 383
Date d'inscription : 18/04/2019
Age : 68
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Pascal25 Ven 10 Nov 2023 - 20:01

Bonjour,

La case "EU" permet de masquer le protocole D8 dans le menu d'appairage du récepteur.
Il nous faudrait connaître la version de la carte HF de la radio, via le menu d'OpenTX.
EU-LBT ou FCC ?
Quelle version ACCST ? V1 ou V2 ?
As-tu flashé aussi la platine HF lors du passage 2.3.11 à 2.3.15 ?
Il n'y a pas d'interaction entre la version d'OpenTX et la version de la platine HF.
Si tu as mis à jour la platine HF, il faudra refaire l'appairage des récepteurs.

Pascal25

Masculin Messages : 1962
Date d'inscription : 20/01/2019
Age : 64
Localisation : Pays de Montbéliard

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Jeep1656 Dim 12 Nov 2023 - 18:46

Bonjour et merci Pascal25 pour ta réponse:

NON j'ai flashé le bootloader seulement après téléchargement du firmware et de la version SDcard correspondante.
firmware "opentx-x9d-eu-lua-noheli-fr.bin", rebaptisé firm235.bin dans FIRMWARE de la SD, puis "flasher le bootloader"
Pour la version ACCST je ne sais pas vérifier...il y a des Rx Fr-sky assez anciens, des "AC-410 et 810...bref! affraid
...ils fonctionnaient semble-il...
Ma mémoire revient avec ton aide: la partie HF ne devrait pas être changée avec ces manips.
Un peu de recherche m'ont permis de découvrir que les récepteurs en questions ne fonctionneront qu'en D8.
Si le D8 ne fonctionne qu'en non-EU (FCC), je suis marron!
A moins que je puisse décocher la cas EU et re-télécharger le firmware en OpenTx 2.3.15.
Et je serais surement bon pour re-binder le rX .
qu'en penses-tu ?

Jeep1656
Jeep1656

Masculin Messages : 383
Date d'inscription : 18/04/2019
Age : 68
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Pascal25 Dim 12 Nov 2023 - 20:16

Bonsoir,

Le mode D8 fonctionne parfaitement en EU-LBT, en ayant décoché la case EU.
Reflashe ta radio sans cocher la case EU et tu devrais retrouver ce mode.
A priori, pas besoin de refaire l'appairage, puisque tu n'as pas flashé la platine HF.

Pascal25

Masculin Messages : 1962
Date d'inscription : 20/01/2019
Age : 64
Localisation : Pays de Montbéliard

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Jeep1656 Dim 12 Nov 2023 - 21:58

Merci Pascal,
en effet, çà va mieux!

par contre l'AC410 que j'ai pour l'instant en test doit avoir un fail-safe enregistré.
Je ne trouve plus l'accès au paramétrage du Failsafe dans la X9D.
rien dans Companion?
je crois me rappeler qu'en D8 on n'a pas de failsafe programmable à l'émetteur ou Companion

cela vient sans doute du récepteur AC410: j'ai trouvé une info disant que seule la voie3 passe au minimum en Failsafe.
si çà se trouve on n'y peut rien
Pas cool...
Je vais voir avec le propriétaire, s'il peut me passer un vrai FRSky, je crois qu'il à un D8R II
Jeep1656
Jeep1656

Masculin Messages : 383
Date d'inscription : 18/04/2019
Age : 68
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Pascal25 Lun 13 Nov 2023 - 11:29

Oui, le failsafe est à programmer directement sur le récepteur qui utilise le mode D8.
Certains récepteurs D8 ne gèrent d'ailleurs qu'une seule voie pour le failsafe, ce qui oblige d'y mettre la voie des gaz. Généralement la voie 3.

Pascal25

Masculin Messages : 1962
Date d'inscription : 20/01/2019
Age : 64
Localisation : Pays de Montbéliard

Revenir en haut Aller en bas

COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES Empty Re: COMPATBILITE ENTRE VERSION TX X9D ET VERSION RX DIFFERENTES

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum