Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment :
Fnac : 15% de réduction sur toutes les TV de ...
Voir le deal

Taranis X9e qui ne démarre plus

3 participants

Aller en bas

Taranis X9e qui ne démarre plus Empty Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 10:38

Passage de Futaba 41MHz à Taranis X9e la semaine dernière. Et me voilà plongé dans l'informatique pour configurer ma radio, avec de l'aide mais mon problème persiste.
Radio reçu avec une version de 2015 ne permettant pas d'avoir les pages de télémétrie, ce qui était ma principale motivation pour passer de ma vieille radio à une nouvelle afin d'avoir un vario.
La mise à jour vers la version 2.3.9 a été faite par le président de mon club qui a la même radio, mais message d'erreur avec l'EEPROM et impossibilité d'appairer le récepteur.
Je cherche comment mettre à jour l'EEPROM car même s'il y avait un message conversion à la mise en route, cela ne changer rien.
Du coup je suis arrivé au moment fatal où j'ai certainement (c'est même sur) flasher un mauvais bootloader. Et depuis plus rien, elle ne veut plus s'allumer, le bouton POWER ne fonctionne plus.
Donc étude du forum et j'ai utilisé la procédure permettant le passage d'open TX 1.x vers 2.0.20.
Radio éteinte (forcement elle ne s'allume plus), utilisation de Zadig, STM32 BOOTLOADER, OK sur Périphériques Universal Serial Bus, Companion 2.3.9, pas de vérification de version, transfert vers la radio, 100% sans message d'erreur, je débranche avec beaucoup d'espoir et toujours rien. Impossible d'allumer la radio.
J'ai bien sur tester les 2 modes de mises en route, j'ai fais plusieurs fois le flashage, mais rien n'y fait.
Mon dernier espoir c'est vous et votre expérience.
Je n'ai peut être pas trouvé le même cas sur le forum car je suis nouveau, j'ai vu écran bleu, blocage de la radio, mais les solutions sont souvent un reflashage en redémarrant en pinçant les trims mais ce n'est pas possible dans mon cas.

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par LapinFou Mar 25 Aoû 2020 - 10:50

La solutions Zadig est la bonne.
Par contre, es-tu sûr d'injecter le bon firmware ?
Les firmwares pour les X9D, X9D, X9D+, X9D+ 2019 et X9E (ta radio pupitre) sont tous différent ! Taranis X9e qui ne démarre plus 2258904616
Si tu injectes avec Zadig le bon firmware, il n'y pas de raison que cela ne fonctionne pas.

1. Stresse pas, c'est impossible de "bricker" une Taranis. Il y a toujours un moyen d'injecter le bon firmware.
2. Assures-toi que le cordon USB que tu utilises est de bonne qualité et le plus court possible. Les Taranis sont un peu capricieuse de ce côté là. Taranis X9e qui ne démarre plus 2258904616

_________________
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. Taranis X9e qui ne démarre plus 2258904616

Taranis X9e qui ne démarre plus Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek


OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 15753
Date d'inscription : 09/09/2014
Age : 46
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 11:06

C'est bien le firmware X9e, nous l'avions déjà flasher avant que je fasse la "bétise" et j'ai également bien verifier dans companion car j'avais vu qu'il fallait prendre le bon firmware.
La connexion avec ma radio se fait correctement, le cable ne fait que 40cm, d'une bonne épaisseur et la radio répond par un bip quand je le connecte. après est-ce que toutes les données passent bien ???
Je vais tester avec un autre cable.
Concernant l'utilisation de Zadig, j'ai suivi à la lettre la procédure, mais franchement je n'y comprend rien.
Merci pour ta réponse très rapide.

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par 3djc Mar 25 Aoû 2020 - 11:54

Merci de mettre le details du log de flash (cliquer sur 'show details' sur la fenêtre de flash)
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 12:43

Si j'ai bien compris la question, tu me demandes les informations du flashage. Dans la fenêtre "Tranférer le firmware à la radio, j'ai :
Programmation terminée
La barre verte avec 100%
Puis les détails :
C:/Program Files (x86)/OpenTX/Companion 2.3/dfu-util.exe -a 0 --dfuse-address 0x08000000 --device 0483:df11 -DD:/Modelisme/TARANIS fichier pour config/opentx-x9e-eu-noheli-fr.bin
=================================================================================
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x0483 product = 0xdf11
More than one DFU capable USB device found, you might try `--list' and then disconnect all but one device

=================================================================================

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 12:45

Je viens de reflasher en changeant de cable.
J'ai bien un bip à l'ordi chaque fois que je branche et je débranche.
Toujours pas possible d'allumer la radio

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par 3djc Mar 25 Aoû 2020 - 12:55

S'il y a que ca c'est pas bon, il a pas flash
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 13:03

Voilà donc le problème. Toutes mes manip n'ont jamais rien changé au contenu de la radio.
Mais comment flasher correctement ?
J'ai essayé 3 cables dont 2 de 40cm.
Est ce qu'il y a une opération que j'ai loupée ?
Quand je branche ma radio, dans le gestionnaire de périphériques il s'affiche :
Périphériques Universal Serial Bus
STM32 BOOTLOADER
Ceci suite à la manip avec ZADIG. Cela suffit il à connecter correctement l'ordinateur et la radio ?

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Chris Mar 25 Aoû 2020 - 13:12

SUPER, MERCI, j'ai réussi.
Exactement la même manip mais en changeant de port USB sur mon ordinateur.
J'ai encore cette alerte EEPROM message

EEprom Data v217
Touche pour continuer

Cela me fait conversion EEPROM

Mais ça ne change rien lorsque je remets en route j'ai à nouveau le même message.
Où peut on trouver le bon fichier pour reflasher l'eeprom afin de ne pas refaire la mauvaise manip.
Dans cette config je ne peux pas binder mes recepteurs.

Chris

Masculin Messages : 12
Date d'inscription : 25/08/2020
Age : 59
Localisation : Herault

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par 3djc Mar 25 Aoû 2020 - 14:50

le bind n'a rien a voir avec tout ca. Le soucis d"'eeprom est que tu a sauté des versions. Si tu a une sauvegarde companion, tu devrais faire un eeprom reset
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 54
Localisation : Belgique

Revenir en haut Aller en bas

Taranis X9e qui ne démarre plus Empty Re: Taranis X9e qui ne démarre plus

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum