Le forum français des radios FrSKY

Simulateur 2.1.9 et 2.2.2 en FR

Page 10 sur 10 Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par LapinFou le Ven 26 Oct 2018 - 18:16

J'ai fait un switch sur OTX 2.2.1 et là, miracle !! J'ai pu générer les DLLs.

Par contre dés que je switch sur OTX 2.2.2, j'ai ce message d’erreur:

Code:
 Generating font_03x05.lbm
  Traceback (most recent call last):
    File "C:/Git/opentx/opentx/radio/util/img2lbm.py", line 6, in <module>
      from PIL import Image
  ImportError: No module named PIL
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.CppCommon.targets(171,5): error MSB6006: Arrêt de "cmd.exe" avec le code
 1. [C:\opentx\build\radio\src\bitmaps\212x64\taranis_fonts.vcxproj]
Génération du projet "C:\opentx\build\radio\src\bitmaps\212x64\taranis_fonts.vcxproj" terminée (cibles par défaut) -- ÉCHEC.

albino
avatar
LapinFou

Messages : 9400
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par 3djc le Ven 26 Oct 2018 - 18:23

Il faut python pillow

3djc
avatar
3djc

Messages : 1751
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par Cedric Lag le Ven 26 Oct 2018 - 18:26

Bonsoir à tous,

Parmi le pack fr pour le simu 2.2.2, il y a une absence...
Possible à l'occasion d'avoir le fichier dll pour l'x-lite ?

Merci, bonne soirée.

Cédric
avatar
Cedric Lag

Messages : 48
Date d'inscription : 22/12/2017
Age : 40
Localisation : Saint Loup Géanges (71)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par dev.fred le Ven 26 Oct 2018 - 20:34

Tu n'as pas vue la dernière ligne de mes notes, bon c'était un peu dense :
Depuis la 2.2.2 installer Pillow-5.1.0.win32-py2.7.exe  https://pypi.org/project/Pillow/#files

en faite c'est passé en 5.3 -> Pillow-5.3.0.win32-py2.7.exe

dev.fred

Messages : 581
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par dev.fred le Ven 26 Oct 2018 - 20:50

Cedric a écrit:Possible à l'occasion d'avoir le fichier dll pour l'x-lite ?

Je l'ai ajouté au fichier zip de la 1ère page

dev.fred

Messages : 581
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par dev.fred le Ven 26 Oct 2018 - 21:16

@Lapinfou

Par contre dans ton tuto, tu utilisais une boucle for -> tu peux utiliser les 2, je ne sais + pourquoi je suis passé à l'autre écriture, cela a dû m'arranger ...

quelles sont les étapes à faire lorsqu'une nouvelle version d'OpenTX sort. -> je charge le fichier zip du source ici : [Vous devez être inscrit et connecté pour voir ce lien] et j'ajoute le répertoire build avec le fichier cmd comme déjà évoqué.

Dernière question, comment faire un "make clean". -> c'est possible sous firmware grâce au fichier Makefile construit après l’exécution du fichier .bat

-- Looking for pthread.h
-- Looking for pthread.h - not found -> même message mais comme il fini correctement c'est qu'il ne l'utilise pas : -- Build files have been written to: C:/opentx/build



dev.fred

Messages : 581
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par Cedric Lag le Sam 27 Oct 2018 - 10:10

dev.fred a écrit:Je l'ai ajouté au fichier zip de la 1ère page

Merci c'est super sympa Very Happy
avatar
Cedric Lag

Messages : 48
Date d'inscription : 22/12/2017
Age : 40
Localisation : Saint Loup Géanges (71)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par 3djc le Sam 27 Oct 2018 - 10:23

Ca fait un moment que je me dit que l'on pourrais ajouter les dll des languages, mais soit on les intègre par defaut et on arrive a un installer énorme, soit on les propose en dl additionnel, et le support monte en flèche si on propose des packs externes à téléchargé, quant on voit le nombre de gens qui n'arrive pas a copier un pack de son, ça fait peur. Je garde ca dans un coin de mon esprit ceci dit

3djc
avatar
3djc

Messages : 1751
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par dev.fred le Dim 28 Oct 2018 - 10:42

Je me suis rapproché des options utilisées par les devs : [Vous devez être inscrit et connecté pour voir ce lien]
j'ai dû malgré tout en retirer certaines car j'avais le message :
Code:
CMake Warning:
  Manually-specified variables were not used by the project:

    AUDIO
    GAUGES
    GPS
    TELEMETRY
    VARIO

Code:
SET OPENTX_VERSION_SUFFIX=
SET COMMON_OPTIONS=-G "Visual Studio 14" ..\ -DCMAKE_PREFIX_PATH=C:\Qt\Qt5.7.0\5.7\msvc2015 -DGVARS=YES -DHELI=YES -DLUA=YES -DMULTIMODULE=YES -DPPM_LIMITS_SYMETRICAL=YES -DAUTOSWITCH=YES -DAUTOSOURCE=YES -DPPM_CENTER_ADJUSTABLE=YES -DFLIGHT_MODES=YES -DOVERRIDE_CHANNEL_FUNCTION=YES -DFRSKY_STICKS=YES -DTRANSLATIONS=FR

cmake %COMMON_OPTIONS% -DPCB=X9D
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=X9D+
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=X9E
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=X7
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=X10
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=X12S
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

cmake %COMMON_OPTIONS% -DPCB=XLITE
"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" radio\src\targets\simu\libsimulator.vcxproj /p:Configuration=Release

J'ai remis à jour mon zip 2.2.2 en 1ere page

dev.fred

Messages : 581
Date d'inscription : 07/02/2014
Localisation : Paimpol (22)

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par Ceeb182 le Dim 28 Oct 2018 - 11:11

3djc a écrit:Ça fait un moment que je me dit que l'on pourrais ajouter les dll des langages, mais soit on les intègre par défaut et on arrive a un installeur énorme, soit on les propose en dl additionnel, et le support monte en flèche si on propose des packs externes à téléchargé, quant on voit le nombre de gens qui n'arrive pas a copier un pack de son, ça fait peur.
Suggestion : Seuls les dll en langue anglaise sont intégrées dans l'installeur, mais au cours de l'installation, l'installeur propose le téléchargement d'une ou plusieurs langues supplémentaires (présentes sur le dépôt d'OpenTx) qu'il se charge seul de télécharger et d'installer correctement (pour éliminer le support additionnel). Ainsi, s'il n'y a aucune connexion internet ou si les fichiers sont indisponibles sur le dépôt, il reste toujours possible d'installer Companion en langue anglaise par défaut sans les langues additionnelles.

Évidemment, c'est sans doute plus facile à dire qu'à faire.
avatar
Ceeb182

Messages : 661
Date d'inscription : 29/10/2016
Age : 43
Localisation : France

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par LapinFou le Jeu 1 Nov 2018 - 16:02

dev.fred a écrit:Tu n'as pas vue la dernière ligne de mes notes, bon c'était un peu dense :
Depuis la 2.2.2 installer Pillow-5.1.0.win32-py2.7.exe  https://pypi.org/project/Pillow/#files

en faite c'est passé en 5.3 -> Pillow-5.3.0.win32-py2.7.exe
Effectivement c'est bien ce qu'il manquait.
Merci à toi et 3djc.
Je peux maintenant compiler les DLL Fr. Very Happy


albino
avatar
LapinFou

Messages : 9400
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: Simulateur 2.1.9 et 2.2.2 en FR

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 10 sur 10 Précédent  1, 2, 3, 4, 5, 6, 7, 8, 9, 10

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum