Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Le Deal du moment :
Cartes Pokémon Japon : le display ...
Voir le deal

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

5 participants

Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par 3djc Jeu 2 Jan 2020 - 16:57

Euh, les widgets sont sauves par modèles, donc il faut écrire le nom une fois, et c'est tout
3djc
3djc

Masculin Messages : 2870
Date d'inscription : 25/09/2016
Age : 55
Localisation : Belgique

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par atoff Jeu 2 Jan 2020 - 20:28

bonsoir Jean-Michel,

Dans le code de ton widget tu peux utliser ceci:
local ModelInfo = model.getInfo()

et ensuite ModelInfo.name pour afficher le nom de ton modèle


atoff

Masculin Messages : 44
Date d'inscription : 12/11/2019
Age : 51
Localisation : Bastogne

http://http:\\www.hmcb.be

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par atoff Jeu 2 Jan 2020 - 21:27

Je n'ai pas le code du widget MyLabel, donc je ne peux pas te dire.

Ce que je te donnais c'est le code que j'ai utilisé dans mes widget pour faire apparaitre le nom du modèle. Je croyais que c'était ce que tu recherchais.

J'ai écris quelques widgets pour mes modèles et les capteurs dont je dispose.

Le 1er, MyGas, me permet d'afficher les infos du module GasSuite:Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Mygass10

ce widget prend tout l'écran.

Le 2e widget s'appelle MyModel, il utilise 1/4 d'écran et affiche l'image du modèle et son nom:
Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Screen10



atoff

Masculin Messages : 44
Date d'inscription : 12/11/2019
Age : 51
Localisation : Bastogne

http://http:\\www.hmcb.be

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par atoff Jeu 2 Jan 2020 - 22:27

Jean-Michel a écrit:My label ou autre solution me convient.
Ton deuxième widjet me convient.
Pourrais tu s'il te plait le modifier pour un 8iemed'écran avec juste le nom ?
C'est compliqué d'écrire un widjet ?
Bonne soirée, ou bonne nuit

voilà en attach le widget, très rapidement, sans beaucoup de tests...
après tu peux ajuster la taille et la position.

Fichiers joints
Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Attachment
MyJM.zip Vous n'avez pas la permission de télécharger les fichiers joints.(36 Ko) Téléchargé 24 fois

atoff

Masculin Messages : 44
Date d'inscription : 12/11/2019
Age : 51
Localisation : Bastogne

http://http:\\www.hmcb.be

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par atoff Jeu 2 Jan 2020 - 22:36

tu unzip et tu mets le contenu sur la carte SD de ta radio, dans le répertoire widget.
tu redémarre ta radio...
ensuite tu vas dans le menu telemetrie, et tu verras le widget MyJM Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) 2258904616

atoff

Masculin Messages : 44
Date d'inscription : 12/11/2019
Age : 51
Localisation : Bastogne

http://http:\\www.hmcb.be

Revenir en haut Aller en bas

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par Mipel Ven 3 Jan 2020 - 0:06

Bonsoir ,
Peux tu partager les 2 widgets indiqués ci-dessus, ils m'intéressent aussi. Merci

_________________
Electrique :
Avions: extra 330sc, clik R2 + mini-polyclub en indoor
Planeurs: Gem, Serenity et Typhoon
Hélicos: Trex 250-450-550
Drones: Wizard X220, Aurora 90 vol à vue+fpv
Thermique :
Extra 300 78'' avec DLE 35RA


Besoin d'infos ? https://opentx-doc.fr/ (co-admin du site avec LapinFou)
Mipel
Mipel
Modérateur

Masculin Messages : 2990
Date d'inscription : 08/06/2017
Age : 64
Localisation : 85 Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par diiity Sam 4 Jan 2020 - 11:37

Jean-Michel a écrit:Voici l'affichage que je retiens.

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Pb220010

Problème :

Je voudrais afficher le nom du modèle en haut à droite.
Avec "My label", il faut taper le nom chaque fois que l'on change de modèle. Ca va pas.
Avec "model BMP, ça passe pas sur les petites fenestres. A cause de la possibilité d'image sans doute, je n'ai besoin que du nom.

Alors si vous avez un truc, ce serait super.

Ma radio commence à être au point, reste les annonces de figures, mais ça va aboutir, c'est sur.

Merci à tous.
Bonjour,
Peux tu expliquer comment tu as fait pour avoir cet écran?

De mon coté, voici ce que je fais:
dans l'écran télémétrie, j'ajoute une page, je sélectionne mylabel comme widget, je le configure et la il n'y a que les 6 lettres de mylabel que je puisse modifier, je ne comprends pas!
diiity
diiity

Masculin Messages : 1836
Date d'inscription : 21/04/2015
Age : 69
Localisation : beauvais

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par diiity Sam 4 Jan 2020 - 19:56

Avec le programme de atoff, je n'ai que le nom de mon modèle et rien d'autre.

Par contre je vois que sur le tien il y a mylabel et d'autres indication en blanc, comment as tu fait?
diiity
diiity

Masculin Messages : 1836
Date d'inscription : 21/04/2015
Age : 69
Localisation : beauvais

Revenir en haut Aller en bas

L'auteur de ce message est actuellement banni du forum - Voir le message

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par diiity Sam 4 Jan 2020 - 21:44

merci
diiity
diiity

Masculin Messages : 1836
Date d'inscription : 21/04/2015
Age : 69
Localisation : beauvais

Revenir en haut Aller en bas

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par atoff Sam 4 Jan 2020 - 23:28

c'est un simple widget qui utilisela fonction model.getInfo().
Cette fonction retourne le nom du modèle actif et son image.
Jean-Michel souhaitait uniquement afficher le nom du modèle.
Pour les 2 autres widgets, j'affiche également leur image.

atoff

Masculin Messages : 44
Date d'inscription : 12/11/2019
Age : 51
Localisation : Bastogne

http://http:\\www.hmcb.be

Revenir en haut Aller en bas

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par diiity Dim 5 Jan 2020 - 0:46

atoff a écrit:c'est un simple widget qui utilisela fonction model.getInfo().
Cette fonction retourne le nom du modèle actif et son image.
Jean-Michel souhaitait uniquement afficher le nom du modèle.
Pour les 2 autres widgets, j'affiche également leur image.

Bonjour,

C'est ce qui m'intéresse est de pouvoir afficher un texte du genre:

SDv dual SE^aérofrein
SFv moteur

etc

mais en widget pas en check-list car elle n'est pas pratique à consulter en vol.
diiity
diiity

Masculin Messages : 1836
Date d'inscription : 21/04/2015
Age : 69
Localisation : beauvais

Revenir en haut Aller en bas

Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu ) Empty Re: Problème Widjet ; quand y en a pu, y en a encore ! ( Résolu )

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum