Le forum français des radios OpenTX ou FrOS
Le forum français des radios OpenTX ou FrOS
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.

N'émet plus !

3 participants

Aller en bas

N'émet plus ! Empty N'émet plus !

Message par Guillaume60 Mer 15 Sep 2021 - 7:57

Bonjour
J'ai travaillé sur un de mes modèles avec Companion 2.3 et après avoir uploadé mes travaux vers la radio, celle ci n'émet plus vers mon modèle !
Elle émet normalement vers les autres modèles, donc le hardware n'est pas en cause.
Je n'ai pas modifié les FW, ceux ci fonctionnaient bien avant mes interventions.
Une idée vers où chercher ?

Merci !
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Mer 15 Sep 2021 - 8:13

En fait, je ne sais pas si elle émet ou non.
Sur companion, la simulation montre que toutes les voies sont figées et ne varient plus avec les manches...
Kézako ?
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Thierry94 Mer 15 Sep 2021 - 9:34

Bonjour,
Étonnant ... si les voies ne bougent plus sur le simulateur c'est qu'il y a quelque chose dans la programation du modèle qui coince ! tu peux poster le fichier du modèle qu'on jette un coup d'oeil ?

Thierry94

Masculin Messages : 524
Date d'inscription : 28/01/2016
Localisation : Ile de France

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Mer 15 Sep 2021 - 9:56

Plus je regarde, plus c'est incompréhensible ... les manches sont figés mais S2 bouge ... ??
J'avais essayé vraiment trop de choses et je crois que la programmation avait gardé des bizarreries en mémoire quelque part. D'où blocage ?
J'ai tout repris à propre et on va voir.
Merci de ta réponse
Bonne journée
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Jeu 16 Sep 2021 - 10:06

Bonjour

Les chaussettes m'en tombent !
J'ai effacé le modèle et l'ai recréé complètement, avec re Bind.
Il fonctionne bien sous simulation dans Companion mais ... rien ne bouge sur le modèle.
Tous mes autres modèles vont bien.

Je vais extraire le fichier et le poster dans 5 min

Merci !
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Jeu 16 Sep 2021 - 10:22

Comment fait on pour poster ici le fichier qui correspond au modèle ?
Merci
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Jeu 16 Sep 2021 - 11:16

Problème résolu.

Cela provenait de mes entrées: j'avais assigné 'voie1 Gaz' au lieu de 'gaz' dans le menu déroulant. Etc.
je ne comprends toujours pas la différence entre ces deux types de définitions.
Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Pascal25 Jeu 16 Sep 2021 - 13:19

Bonjour,

Gaz correspond à la valeur du manche de gaz.
Voie1: Gaz correspond à la sortie de la voie 1, qui a été définie par la page mixage.

Dans la logique d'OpenTX, il faut généralement définir une entrée, qui reçoit l'information d'un actuateur physique, comme le manche de gaz. La valeur du manche de gaz s'appelle Gaz est sera affectée à l'entrée E1:Gaz dans la page entrées.
C'est à cet endroit que l'on définit les dualrates (Bien sûr, pas pour les gaz...). Tu comprends donc que la valeur de l'entrée E1:Gaz pourrait être différente de la valeur du manche de gaz.

Cette entrée est ensuite utilisée dans la page mixages, où elle est affectée à une sortie voie. Le résultat du calcul fait par le mixage est la valeur Voie1:Gaz.

Dans ton cas, tu as défini une entrée comme étant issue de la valeur de sortie ! Cela ne peut donc pas fonctionner !

Je te conseille de réviser les diagrammes de flux qui pourront t'aider à comprendre la logique.

Et si tu as des doutes ou des incompréhensions, n'hésites pas à revenir les exprimer ici !

Pascal25

Masculin Messages : 1096
Date d'inscription : 20/01/2019
Age : 61
Localisation : Pays de Montbéliard

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Guillaume60 Jeu 16 Sep 2021 - 13:25

Merci Pascal.
Je comprends mieux !
Je vais aller revoir les diagrammes des flux, j'en ai besoin ...
Bons vols !

Guillaume60
Guillaume60

Masculin Messages : 117
Date d'inscription : 31/01/2018
Age : 68
Localisation : Sud Oise

Revenir en haut Aller en bas

N'émet plus ! Empty Re: N'émet plus !

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum