Le forum français des radios FrSKY

Première Simulation Quadricopter

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Jeu 17 Juil 2014 - 9:17

CoyotteDundee a écrit:
...Et n'oublie pas d'enlever les hélices durant toute cette phase de réglage  Bienvenue   !!!!
Coyotte
Eh, oui. Je n'ai pas encore mis les hélices et je ne suis pas prêt à le faire avant d'avoir fait le tour.

Ma Naze32, je l'ai déjà programmée pour les fonctions de base :

- Mode PPM
- Motor-Stop (les moteurs ne tournent pas à l'armement)
- Yaw à 90° (l'avant de la nasze32 est tourné à droite
- l'ordre des voies RTEA1234)

j'ai un retour de télémétrie sur la Taranis que je ne comprends pas (environ 4,7V). Je suppose que c'est la tension que reçoit la carte, car je n'ai pas de télémétrie installée.
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par Murphy le Jeu 17 Juil 2014 - 12:05

cubitusclaudius a écrit: j'ai un retour de télémétrie sur la Taranis que je ne comprends pas (environ 4,7V). Je suppose que c'est la tension que reçoit la carte, car je n'ai pas de télémétrie installée.

Les récepteur X8 et D8 fournissent tous une tension Rx. C'est la tension aux bornes de ton récepteur et qui est fourni par le UBEC du controleur. Certainement mal réglé en télémetrie car tu devrais avoir entre 5V à 5,5V. En télémétrie il faut régler A1 à 13,5V.

_________________
Encore là...
X9D+ EU-LBT 2.1.9,
Horus EU-LBT 2.2.0

Forum du club ACPM
avatar
Murphy
Modérateur

Messages : 5919
Date d'inscription : 27/08/2013
Age : 72
Localisation : Montbéliard, près de la Suisse

http://bethoncourt-indoor.forumgratuit.org/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Jeu 17 Juil 2014 - 15:17

Murphy a écrit:
cubitusclaudius a écrit: j'ai un retour de télémétrie sur la Taranis que je ne comprends pas (environ 4,7V). Je suppose que c'est la tension que reçoit la carte, car je n'ai pas de télémétrie installée.

Les récepteur X8 et D8 fournissent tous une tension Rx. C'est la tension aux bornes de ton récepteur et qui est fourni par le UBEC du contrôleur. Certainement mal réglé en télémétrie car tu devrais avoir entre 5V à 5,5V. En télémétrie il faut régler A1 à 13,5V.
Merci Murphy. C'est fait (moi c'est un D4) mais la valeur reste à 4,97V Je vais aller voir si je eux faire qque chose sur Baseflight.
Ah, par contre quand je plante le port USB dans la carte, le voltage est à 5,02V (la lipo est à 11.2V actuellement)

Que penses-tu le la phase de vol 0 : est-ce que c'est une phase pour ne pas voler? Sinon, pourquoi la Naze32 ne réagit pas à l'Armage/désarmage?
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Jeu 17 Juil 2014 - 15:47

CoyotteDundee a écrit:Tu pourrais stocker cela dans une voie inutilisée.
Avantage : Au démarrage, la voie est toujours à 0, donc le système est toujours désarmé au départ.
Tu armes avec GAZ à zero et DIR à +100
tu désarmes avec ? (Gaz à 0 et DIR à -100 ? )

Je prends la voie 10 comme étant inutilisée part ton modèle, L10 qui détecte la combinaison d'armement et L11 la combinaison de désarmement.
Code:

VOIE 10    (100%) VOIE 10
         R (+100%) MAX SWITCH L10
         R (%0) MAX SWITCH L11

Tu armes, la voie 10 passe à +100... Tu désarmes, elle revient à 0.. Tu éteins et tu rallumes, elle est à 0.
(Testé sur la radio. Le simulateur garde la valeur de la voie 10 entre deux simulations sauf à sortir de Companion et à le relancer)
Une piste de réflexion peut-être...

Coyotte
Coyotte, je n'ai pas l'habitude de poser des questions avant d'avoir secoué comme il faut le cocotier.

Mais je n'arrive pas du tout à faire marcher ce code :

d'abord, tu ne disais pas dans quelle rubrique mettre ce code. j'ai cherché partout, et je n'ai vu qu'une solution. C'est dans les Mixages.

la syntaxe ne correspond pas à ce que j'obtiens sur Companion.

J'ai défini sur la Taranis 6 voies seulement à cause des 55Hz Firmware d'origine à 18msec . peut-être ces voies n'ont rien à faire avec les autres et que les mêmes termes sont utilisés pour 2 choses complètement différentes. actuellement j'ai 4 voies utilisées.

Il faut que tu m'en dises un peu plus

avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Jeu 17 Juil 2014 - 16:02

Hello Cubitus,
Avec la Taranis, tu peux utiliser autant de voies que tu le souhaites, même si tu ne transmets effectivement que les 6 premières... (Heu, c'est quoi ce 55hz Firmware d'origine à 18msec ?)

Tu as effectivement trouvé que c'était bien dans les mixages !

Il y a 3 mixages pour la voie 10.
Tu dois donc créer 3 mixes sur la même voie 10
- 1 qui a pour source la voie 10 avec un ration de 100%
- 1 qui a pour source MAX, ratio de 100%, switch L10 Mutiplexage "Remplacer"
- 1 qui a pour source MAX, ratio de 0%, switch L11 Mutiplexage "Remplacer"
Dans le cas présent, c'est une voie virtuelle... Elle n'est pas destinée à être transmise vers le récepteur mais sert à stocker une information.

Comme indiqué dans le post original, les switchs L10 et L11 servent à tester la combinaison d'armement et désarmement (Là, je te laisse implémenter la logique des tests, ne sachant pas quels sont tes critères...)

Ensuite, tu peux ajouter un test du genre
L12 a > x, Voie10 85  

L12 sera alors actif lorsque la voie10 est > 85 et la voie10 est active (à 100) lorsque tu as activé la combinaison d'armement... CQFC :-)

Tu peux déplacer ce code sur une autre voie si la 10 est déjà occupée. De même pour les switchs L10, L11 et L12

J'espère que cela est plus clair... Sinon, n'hésite pas

Coyotte
avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Jeu 17 Juil 2014 - 18:10

Ça y est. Tout compris. J'espère tester ça ce soir. Le D4R-II a un firmware cadencé à 18ms. Si tu utilises. 8 voies à fond, il plante. Mais 6 O.K.
tu peux le cadencer à 27ms (changement de Firmware) tu peux mettre 8 voies
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Jeu 17 Juil 2014 - 19:55

Ok... Merci pour les explications !

Bon amusement !

Coyotte
avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Jeu 17 Juil 2014 - 22:10

Oui, c'est vraiment fun, mais des fois je stresse pas mal,  surtout avec les commandes les livraisons, les pièces manquantes.
j'ai oublié dans mon explication: 18ms = 55hz 27ms = 33Hz. A mon stade, je pourrais tout à fait passer a 27msec. C'est juste pour l'extrême agilité que ça peut manquer de pêche.

En plus, il faut commander un cordon spécial pour faire l'update.
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Ven 18 Juil 2014 - 8:00

Hello Cubitus...
9 ms de plus pour un cycle aurait un impact sur l'agilité ?
Je suis surpris... D'autant que les réactions du Quad dépendent de la carte contrôleur, pas du récepteur qui ne fait "que" transmettre tes ordres...
Et le temps de réaction humain est largement supérieur à 27 ms...

Je ne vois pas bien où ces 9ms influent ... Mais je suis toujours ravi d'apprendre :-)

Bien à toi,

Coyotte
avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Ven 18 Juil 2014 - 9:09

Coyotte, je n'ai jamais testé. Je l'ai lu.

testé ton code. Ça marche parfaitement. Merci encore.

ce que je n'ai toujours pas tiré au clair, c'est pourquoi la Naze32 ne s'arme pas en phase de vol 0? Murphy, toi qui as une Naza, si j'ai bien compris, arrives-tu à l'armer en phase de vol zéro? Ou c'est un mode de "non-vol"?
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Ven 18 Juil 2014 - 9:53

Hello Cubitus,

A ma connaissance, la phase de vol 0 ne diffère en rien de la phase de vol 1, 2 ou 3...
C'est probablement ta configuration qui fait en sorte que l'armement ne se fait pas dans cette phase.
Si tu fournis ton fichier eepe, il sera peut-être possible de t'aiguiller dans la bonne direction...

Bien à toi,

Coyotte
avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Ven 18 Juil 2014 - 10:44

Merci Coyotte, mais ça m'étonne que ce soit ma programmation étant donné que ce n'est pas moi qui programme l'armement de la Naze32. Mais bon, je suis vraiment novice.
Seulement, avant, je préfère comprendre quelle est l'instruction qui fait que la Naze32 s'arme.

moi, ce que je fais, c'est rendre les sticks actifs/inactifs
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Ven 18 Juil 2014 - 11:03

Cubitus,
A ma connaissance, ta Naze s'arme avec une combinaison de sticks (Croisés comme l'indique Murphy)...
Il y a bien un moment où ta radio envoie la combinaison d'armement (soit parce que tu bouges les manches, soit parce que la combinaison est associée à un interrupteur, soit... )

Dans la doc de ta Naze il doit y avoir l'explication qui indique comment l'armer.
Dans ta programmation de radio, il doit y avoir un moment où la commande d'armement est envoyée...
Faire le parallèle entre les deux devrait t'aider à trouver la source du problème.

Maintenant, n'étant pas Madame Irma, je ne saurai pas t'en dire plus; même regardant dans mon café... Sans fichier EEPE il est quasi impossible de déterminer là où le bât blesse...
Bien à toi,

Coyotte,
avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Ven 18 Juil 2014 - 16:38

Coyotte,

J'ai  ramé, mais j'ai trouvé. En fait il faut connaître les caractéristiques de la Naze32 : Dans la phase de vol 0, je définissais D, P et A à 60% en phase 2 à 80% et en phase 3 à 100%
Or la Naze32 arme et désarme à environ 78% de DIR à droite (gauche). Donc phase 0 pas assez de DIR.  Very Happy 

Ce qui m'a trompé est que je pensais que cette valeur tournait vers 98%.
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par CoyotteDundee le Ven 18 Juil 2014 - 17:40

Cubitus,

Tu as définitivement la meilleure approche : Tu cherches et tu trouves !

Comme disait Julos Beaucarne :
Des chercheurs qui cherchent on en trouve...
Des chercheurs qui trouvent on en cherche ! Wink

Bonne fin de journée,

Coyotte

avatar
CoyotteDundee

Messages : 1716
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par attafr le Ven 18 Juil 2014 - 22:16

cubitusclaudius a écrit:En fait, tout ce que j'ai programmé fonctionne. Il y a juste cette bizarrerie sur la phase de vol 0 qui fait que l'armement/désarmement de la Naze32 ne s'effectue pas.

Évidemment, pour l'instant pas question de mettre les hélices, mais les moteurs s'enclenchent, tournent dans le bon sens, accélèrent quand je mets les gaz, les 4 directions correspondent entre la Naze32 et la Taranis

maintenant, mes modes de vol, c'est du gadget. le mode normal c'est celui que j'ai nommé mode "nerveux" (phase de vol 2) où les mouvements des sticks sont à 100%=100% (dans les autres modes les sticks ne délivrent que respectivement 60% et 80%, sauf les gaz que je n'ai pas touchés).

J'ai fait le check des moteurs sur Baseflight Configurator. ils démarrent à 1081 sauf 1 qui est un peu plus faiblard et qui hoquette à 1081. Mais le petit cran au dessus, ils tournent tous. De toutes façons, je compte bien prendre mon temps et faire les choses proprement.

Là je vais me coucher, et demain, jour de congé. La Taranis va rester dans sa boite...

Si tes sticks ne délivre que +60% (ou -60%) il n'arriveront pas au 1100 ou 1880 (exemple...) nécessaire pour amorcer ou désamorcer la carte. stick en bas à droite pour démarrer...

Pour les moteurs, ça a réglé le problème la calibration ?

A+
avatar
attafr

Messages : 101
Date d'inscription : 05/02/2014
Age : 60
Localisation : Genève (Suisse)

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Sam 19 Juil 2014 - 19:11

Oui Attafr. la calibration a marché nickel. J'ai maintenant également la télémétrie, mais évidemment ce n'est pas par cellule, donc je garde le Saver quand même par précaution. On verra à l'usage si on peut s'en passer.

Petite question pour les cracks : Y a-t-il moyen d'interroger l'armement de la Naze32 sur la Taranis? style "ARM"?
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Mar 22 Juil 2014 - 9:32

Bon, Il n-y a pas foule au portillon. Tant pis, je rajoute une question : Je n'ai toujours pas trouvé comment commander un Failsafe sur la Naze32 Acro depuis la Taranis sans éteindre cette dernière.
Ce serait utile pour tester le Failsafe et re-switcher immédiatement en cas de problème.

De toutes façons je me choisirai un champs assez grand pour faire le test. La valeur de 1200 que met la carte me semble assez faible - c'est presque de la chute libre il me semble, non?
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par Murphy le Mar 22 Juil 2014 - 14:37

Pour tester le failsafe il te suffit de te mettre en essai de porté sur la Taranis. Donc ton engin à une centaine de mètres ou plus, tu passes en assai de porté dans la config du modèle (donc émission 1mW environ) et là tu verras si le failsafe fonctionne. Si ça va pas tu annules de suite l'essai de porté.

Sinon sur le Naza il y a aussi une programmation du failsafe possible. Je fait cela par un inter.

_________________
Encore là...
X9D+ EU-LBT 2.1.9,
Horus EU-LBT 2.2.0

Forum du club ACPM
avatar
Murphy
Modérateur

Messages : 5919
Date d'inscription : 27/08/2013
Age : 72
Localisation : Montbéliard, près de la Suisse

http://bethoncourt-indoor.forumgratuit.org/

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Mar 22 Juil 2014 - 16:30

Murphy a écrit:Pour tester le failsafe il te suffit de te mettre en essai de porté sur la Taranis. Donc ton engin à une centaine de mètres ou plus, tu passes en assai de porté dans la config du modèle (donc émission 1mW environ) et là tu verras si le failsafe fonctionne. Si ça va pas tu annules de suite l'essai de porté.

Sinon sur le Naza il y a aussi une programmation du failsafe possible. Je fait cela par un inter.

Merci Murphy, tu me donnes un super indice. Je fais le test dès que la terre sèche.

Quant au Naze32 je peux programmer le Failsafe par le CLI, mais la seule façon que j'ai vu de mettre un inter à contribution c'est la gestion des Auxiliaires et là je n'ai que "ARM" "ANGLE" "HORIZON" "MAG" "HEADFREE" "HEADADJ" "BEEPER" et "OSD SW"

Je pense en plus qu'avec mon Acro, je ne dispose que des modes Angle, Horizon et rien ou ARM pour Acro. pour le beeper, il faut que j'en installe un puissant sur le pin en question (pins du milieu sur les pins battery).
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par .AleX. le Mar 22 Juil 2014 - 21:43

cubitusclaudius a écrit:

Merci Murphy, tu me donnes un super indice. Je fais le test dès que la terre sèche.

Je connais pas du tout le Naze32, mais si ça se passe mal, c'est pas mieux sur de la terre pas sèche justement...

 lol! 

_________________
Tout vole, ce n'est qu'une question de vitesse initiale...
avatar
.AleX.
Modérateur

Messages : 1199
Date d'inscription : 24/11/2013
Localisation : Clermont-Fd(63) ou parfois Annecy(74)

Revenir en haut Aller en bas

Re: Première Simulation Quadricopter

Message par cubitusclaudius le Mar 22 Juil 2014 - 22:06

.Alex, si jamais mon QAV250 se tirait jusqu'en Auvergne, je risque d'être à moto vers les volcans dans 2 semaines.  Wink 
avatar
cubitusclaudius

Messages : 81
Date d'inscription : 25/06/2014

Revenir en haut Aller en bas

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum