Le forum français des radios OpenTX ou FrOS

problème simulateur télémétrie companion 2.3.4

Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty problème simulateur télémétrie companion 2.3.4

Message par Jeep1656 le Lun 13 Jan 2020 - 19:53

Bonsoir,
Je viens de migrer ma X7Q en v2.3.4, sans soucis, j'ai volé avec Samedi: Nickel.
Je voulais tester sur simulateur, avant de migrer ma X9E en v2.3.4, car elle sert aux grands planeurs, c'est plus prudent!
Je rencontre un problème avec le simulateur companion 2.3.4 sur mon profil X9E et sur mon profil X7Q:
Les différents inters et voie proportionnelles fonctionnent, mais quand je veux simuler en télémétrie je n'ai aucun résultat.
Je m'en suis pourtant servi avec succès il y a quelque mois quand j'étais en version 2.3.2?
Normalement j'avais bien le vario et l'annonce de l'altitude, mais là c'est le silence complet.
Par contre j'ai des annonces sur position d'inters, qui fonctionnent correctement.
Je vois aussi les inters logiques bouger...
Pouvez-vous me donner un petit tuyau SVP?
Jeep

Jeep1656

Masculin Messages : 70
Date d'inscription : 18/04/2019
Age : 64
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par LapinFou le Lun 13 Jan 2020 - 22:28

Je crois qu'il y a des petits soucis avec le simulateur de Companion.
Si tu veux tester, il faut lancer un fichier .log d'un vrai vol. Là, cela devrait fonctionner.

LapinFou

_________________
problème simulateur télémétrie companion 2.3.4 Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek

Vous pouvez aussi regarder le
[Vous devez être inscrit et connecté pour voir ce lien]. Veuillez juste noter que je ne le maintiens plus depuis la création du site documentaire.
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. problème simulateur télémétrie companion 2.3.4 2258904616

OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 12252
Date d'inscription : 09/09/2014
Age : 45
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par Jeep1656 le Mar 14 Jan 2020 - 7:57

Merci LapinFou,
Malheureusement, je n'en ai pas encore réalisé.
C'est une fonction que je n'ai pas encore exploitée...y en a tellement!
Je viens de tester sur companion 2.3.2 (installé dans un dossier séparé, sans désinstaller la version 2.3.4):
pareil! çà indique NO DATA dans la page écran télémétrie, en bas.
Penses-tu qu'une réinstallation complète de Companion 2.3.4 apporterait un mieux?

Jeep1656

Masculin Messages : 70
Date d'inscription : 18/04/2019
Age : 64
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par LapinFou le Mar 14 Jan 2020 - 8:14

Non, cela ne changera rien au problème. Ceci dit, si la télémétrie fonctionnait correctement sur ta X9E, il n'y pas de raison connue que cela change avec un passage en 2.3.4. problème simulateur télémétrie companion 2.3.4 2258904616

LapinFou

_________________
problème simulateur télémétrie companion 2.3.4 Anim310                
↓↓↓↓ Merci de cliquer sur le gros lien rouge ↓↓↓↓                                          
[OpenTX-Doc] Base documentaire des radios OpenTX
Maintenant que vous avez tout lu, vous pouvez poser vos questions !  geek

Vous pouvez aussi regarder le
[Vous devez être inscrit et connecté pour voir ce lien]. Veuillez juste noter que je ne le maintiens plus depuis la création du site documentaire.
Pas de support par MP !! Pour garder l'esprit communautaire, on partage tout sur le forum. problème simulateur télémétrie companion 2.3.4 2258904616

OpenTX is user friendly!!! It's just selective about who its friends are....
Wink
LapinFou
LapinFou
Administrateur

Masculin Messages : 12252
Date d'inscription : 09/09/2014
Age : 45
Localisation : Falaise

https://opentx-doc.fr/

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par Jeep1656 le Mar 14 Jan 2020 - 9:45

La télémétrie fonctionne bien entre radio et récepteur, je viens de vérifier. ouf!
C'est seulement le simulateur companion qui ne fonctionne pas en télémétrie (no data)

Je viens de tout désinstaller du PC ce qui concerne Companion, nettoyage des registre et boot du PC.
Réinstallation de Companion 2.3.4, et j'ai re-paramétré les 3 profils que j'utilisais. (j'ai refusé la récupération proposée au premier démarrage).
Donc:
profil X9E :firmware, opentx-x9e-eu-horussticks-lua-noheli-fr-2.3.4
profil X9D :firmware, opentx-x9d-lua-noheli-fr-2.3.4, (celle du copain en non EU)
profil X7Q: firmware, opentx-x7-eu-lua-noheli-fr-2.3.4
même problème du simulateur Companion, partout!

Par contre, en remettant à jour les préférences pour chaque profil radio, j'ai constaté quelque chose au niveau de l'onglet "paramètres de l'application":
dossier de sauvegarde automatique se complète tout seul, systématiquement avec le dernier path que j'avais saisi précédemment sous un profil différent.
bizarre... scratch
Alors que c'est bon dans l'onglet "profil radio", les path écrits pour la SD et la sauvegarde automatique sont bien conservés
exemple:
D:/Mes Programmes/OPEN_TX/Taranis X9E/SDcard-X9E
D:/Mes Programmes/OPEN_TX/Taranis X9E/X9E-SavAuto
et
D:/Mes Programmes/OPEN_TX/Taranis X7Q/SDcard-X7Q
D:/Mes Programmes/OPEN_TX/Taranis X7Q/X7Q-SavAuto
Gérer 3 profils de radios différentes nécessite un grande vigilance et une bonne organisation des dossiers!

Autre constatation, résumé de mes tests:
1/ Lancement du simulateur companion par l'icone "simuler radio en haut de la feuille "modèles ....":
On a bien la X9E, mais l’écran affiche, après un bip: SD Card Warning: expexted version: 2.3V0025
Ce n'est pas le cas sur la radio réelle:(Je n'ai pas encore migré la X9E par précaution (toujours en 2.3.2))

2/ Lancement avec l'icone Firmware Simulateur 2.3 de démarrage Windows:
Pareil!

3/ Lancement "simulation" en bas de la page édition d'un modèle:
On a bien la bonne présentation d'écran de la X9E, pas d'alarme SD, et si on va chercher un écran télémétrie on à No DATA en bas

4/ ces symptômes sont exactement les même avec la X7Q et la X9D, toutes les 2 migrées en v2.3.4


Dernière édition par Jeep1656 le Mar 14 Jan 2020 - 11:31, édité 1 fois (Raison : on n'a pas l'écran)

Jeep1656

Masculin Messages : 70
Date d'inscription : 18/04/2019
Age : 64
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par Jeep1656 Hier à 23:30

bonsoir,
je reviens vers vous après quelques essais.
Sur le conseil de LapinFou, j'ai enregistrer un LOG sur la X9E, en baladant le fuselage dans le séjour et de haut en bas!
J'ai aussi bougé les manches et inters.
Je confirme le bon fonctionnement de la télémétrie en réel, affichage correct des données dans les écrans.
L’émetteur a bien enregistré le LOG, que j'ai récupéré sur le PC.
Je visualise bien les données sur Companion 2.3.4, par Fichier/Ouvrir un Log.
1/ Ouverture du modèle pour lancer Simulation: Toujours pareil, toutes les fonctions actives (inters, manches, sorties, mixeurs,etc), sauf la télémétrie qui semble ne rien transmettre (Simule coché), d'ailleurs le simu affiche NODATA sur les pages affichage télémétrie.
Dans ce test j'ai rempli moi-même les cases Alt et Vspd ce qui faisait bien réagir le simu en V2.2.4 (bruit vario, annonce altitude atteinte) lorsque je l'ai programmé en septembre. En V2.3.4, rien ne réagit plus.
2/ Comme indiqué par LapinFou j'ai ouvert le LOG, la lecture se fait, remplissant les cases du tableau Télémétrie du simu, on voit bien évoluer Alt et Vspd entre autre. Malheureusement toujours rien n'arrive, aucune réaction, NODATA sur les pages affichage télémétrie.
3/ La X7Q et la X9D souffrent du même problème, j'ai fait aussi le test, sous version 2.3.4 et sous version 2.3.5
4/ Testé sur un autre PC, sous windows10, mêmes conditions, même problème.
5/ est-il possible de refaire le test avec Companion 2.2.4, sans rétrograder les radios?
N'y aurait-il pas un bug qui se serait glissé là au cours des dernières évolutions?
Nos amis développeurs sont-ils informés du soucis?

Je trouvais tellement pratique ce simulateur Companion lors du paramétrage d'un nouveau planeur. Sad
Jeep1656

Jeep1656

Masculin Messages : 70
Date d'inscription : 18/04/2019
Age : 64
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par Jeep1656 Aujourd'hui à 0:36

confused
je me réponds tout seul: pas besoin de rétrograder les radios pou tester le Simulateur de Companion 2.2.4: il faut par contre utiliser un modèles sauvegardé en V2.2.x.
Donc, désinstallation complète de Companion 2.3.5 (en fait le soucis existe depuis 2.3.0, où le simulateur a évolué dans son aspect actuel)
Installation de 2.2.4, création du profil radio et récupération d'un fichier modèle d'époque compatible. (sinon çà plante!).
ET là! miracle, la télémétrie est bien transmise au simulateur, on a les valeurs dans les pages affichage télémétrie.

Il y aurait donc bien un truc cassé au changement de branche: Suspect
Cela pourrait venir des deux cases à cocher ajoutée "pause.." et RAZ RSSI..." qui n'y étaient pas dans la branche 2.2.
(c'est le bon vieux jeu des 7 différences...) scratch

ON va attendre l'analyse des pros... problème simulateur télémétrie companion 2.3.4 3357007632
bonne nuit
Jeep1656

Jeep1656

Masculin Messages : 70
Date d'inscription : 18/04/2019
Age : 64
Localisation : Grand Aquitaine - Cognac 16100

Revenir en haut Aller en bas

problème simulateur télémétrie companion 2.3.4 Empty Re: problème simulateur télémétrie companion 2.3.4

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum