Le forum français des radios FrSKY

X9D+ problème de Bind après passage en OTX 2.2.1

Aller en bas

X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 3:14 am

Bonsoir à tous !

J'ai écumé presque tout le forum mais je ne trouve pas de solution à mon problème.
Je vais tâcher d'être clair mais difficile de faire court.

-Je vole depuis plus d'un an avec ma Taranis X9D+ EU LBT en OTX 2.1.6 avec un XSR EU LBT.
-J'ai voulu passer la Radio en OTX 2.2.1 via Companion 2.2.1 avec un nouvel XSR flashé avec le dernier firmware EU LBT mis à dispo par FRSKY.
-Impossible de binder (je suis bien en Eu LBT des deux côté)
-Je repasse le XSR avec le firmware d'origine toujours dispo chez FrSky, ça binde ! mais pas de telemetrie via LUA (normal avec ce firmware).

Bon...

Je me lance dans le build d'un nouveau multirotor avec un autre XSR flashé avec le dernier FW pour voir ce que ça donne. Ça ne binde pas, et maintenant la radio ne veut plus rien binder ! Peut importe le FW du XSR, leds rouge et verte fixes sur les 3 XSR dont un que je n'ai jamais flashé et avec lequel je vole depuis plus d'un an.

Je suis repassé en OTX 2.1.9 via compagnon 2.1.9 en téléchargeant le contenu de la carte Sd 2.1x disponible sur le forum, mise à jour du bootloader en 2.1.9, ecriture l'EEProm.
TOUJOURS RIEN.
Mise à zéro des réglages usine, je pars sur un modèle de base, rien... scratch

Deux, trois choses me turlupinent :
Dans Companion je crée mon "modèle" de Firmware, je lui indique entre autre Mode 2, langue Fr, image d'accueil personnalisée... et je le transfère à la radio.
Je rallume, l’écran d'accueil personnalisé est bien là, par contre la radio est en mode 1 et la zone géographique USA (pas EU !), la langue est bien en Français.
Pas de problème pour remettre de l'ordre dans tout ça via le menu de la radio toutefois étant donné que le mode n'a pas été pris en compte et que la zone géographique par défaut est USA, comment puis-je m'assurer que mon firmware est en EU-LBT (EU coché dans les choix, pas de D8 sur la radio)?

J'ai évité les détails mais je suis passé entre autres par la phase Firmware 2.2.2 EuLbt de chez FrSky sans succès.


Voilà, ça fait plus d'une semaine que je tente de régler mon problème mais là je crois avoir fait le tour de toutes les explications possibles disponibles sur le net (incompatibilité EU vs Non EU / fils trop longs / récepteur trop proche / différence de versions entre FW, SD, Bootloader, EEProm...) mais rien n'y fait.

Désolé c'est un peu long mais j'essaie d'être précis pour tenter d'avoir une explication à mon problème qui m'agace un tantinet puisque j'avais l'intention de profiter de superbes vus du ciel pendant mes vacances d'été.

J'ai fait tellement d'essais que c'est peut-être un truc tout bête à côté duquel je passe à chaque fois, surtout que la radio à l'air de bien fonctionner par ailleurs (pas de messages d'alerte).


Côté XSR j'y crois pas trop puisque au moins un des trois est sur les réglages usine et qu'il a toujours bien fonctionné jusque là. Je l'ai testé en l'alimentant via une PDB vierge pour être sûr que ça ne venait pas d'un problème de config betaflight avec les branchements chelous pour avoir la télémétrie sur la radio (PID, Vtx...).

C'est grave docteurs ?

Merci à ceux qui sont arrivés au bout de ce message !!! Sleep Sleep Sleep Sleep
avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par .AleX. le Jeu 12 Juil 2018, 4:33 am

J'ai regardé qu'en travers, mais je suspecte un problème de module interne, en considérant que le firmware en fait parti.

Donc, une reflashe du module en EU non LBT ou FCC et d'un récepteur 'juste pour voir' me semble à envisager fortement... Wink
avatar
.AleX.

Messages : 1468
Date d'inscription : 24/11/2013
Localisation : Clermont-Fd(63) ou parfois Annecy(74)

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par LapinFou le Jeu 12 Juil 2018, 8:33 am

Changer la version d'OpenTX ne change pas la version du module XJT interne.
La seule chose où OpenTX a un impact, c'est pour cacher/afficher le mode D8 suivant si on coche ou pas l'option de compilation D8.

albino
avatar
LapinFou

Messages : 9552
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 8:50 am

Ha ! Bonjour tout le monde. Merci pour vos réponses.
Donc relativement à mon problème on peut imaginer que ça vient du module interne, mais alors comment le modifier si ce n’est par OTX ? En récupérant un FW et flashant un FW sur FrSky.com par exemple ?
avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 9:01 am

De plus la radio indique bien un firmware 2.1.9, maintenant, donc comment puis-je atteindre/lire/modifier le module interne ?
avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par pointu le Jeu 12 Juil 2018, 9:17 am

Bonjour,

Tu as l'info par là [Vous devez être inscrit et connecté pour voir ce lien]

Si ton xsr est en eulbt tu le saura en passant directement en eulbt ta radio, après il faudra mettre tes autres recepteurs series x/s au meme niveau certainement.
avatar
pointu

Messages : 643
Date d'inscription : 16/11/2014
Age : 55
Localisation : cachan

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par 3djc le Jeu 12 Juil 2018, 9:24 am

Encore une fois OpenTX N'INTERVIENS PAS sur le protocole de communication radio entre le module et le récepteur...

3djc
avatar
3djc

Messages : 1785
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par pointu le Jeu 12 Juil 2018, 9:33 am

3djc a écrit:Encore une fois OpenTX N'INTERVIENS PAS sur le protocole de communication radio entre le module et le récepteur...

3djc
Je suis d'accord, mais la je pense qu'il faut qu'il remette les choses à plat, c'estv parti dans tous les sens :

repasser la radio sur le dernier firwmare 2.2.1
même si cela ne sert a rien mettre le bootloader a jour (comme ça tu as 2.2.1 partout dans les affichages)
reflasher en eulbt sa radio, son xsr.

Tests
avatar
pointu

Messages : 643
Date d'inscription : 16/11/2014
Age : 55
Localisation : cachan

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par pointu le Jeu 12 Juil 2018, 9:35 am

Je pense qu'il était en eu pas en eulbt, et il a le soucis sur un nouvel xsr.
avatar
pointu

Messages : 643
Date d'inscription : 16/11/2014
Age : 55
Localisation : cachan

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 12:36 pm

Merci à tous de vous pencher sur le problème.

La radio à le petit sticker EU LBT à l'arrière, elle était donc initialement en EU LBT ainsi que le  premier XSR puisque jusque là je n'ai jamais rencontré de problème.
À priori en passant en 2.2.1 impossible d'être en EU seulement, la norme LBT étant acquise depuis au moins la 2.1.6 non ?
De même qu'en étant en 2.1.9 maintenant je suis forcément en EU LBT la norme EU simple étant mise de côté non ?

Bon… Ceci étant un truc m'échappe. Le firmware je le télécharge via Companion donc si ce n'est pas lui qui determine le protocole du module interne qu'est ce qui le determine ?
Mais j'ai du coup une petite idée la dessus. Quand je flashe le XSR je pioche dans le dossier Firmware et il me propose de flasher au choix module externe ou module interne.
Est-ce le même Firmware que je dois utiliser pour le module interne ? Mais ça ne colle pas parce que le firmware du module interne ne peux pas être lié à un type de récepteur.
Ou alors un autre Firmware dédié au module interne mais où dois-je chercher ça ? Les tutos ne parlent jamais d'un flashage de module interne lors de la migration vers une version supérieure ?!

Je ne comprend plus rien... je sens que je ne vois pas la forêt cachée derrière l'arbre Sad
avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CoyotteDundee le Jeu 12 Juil 2018, 1:44 pm

Bonjour,

Comme l'a exprimé 3djc ci-dessus, la version d'OpenTX n'a rien à voir avec le protocole EU-LBT ou FCC qui est utilisé par la partie haute-fréquence de la radio.
Donc une simple mise à jour d'OpenTX de 2.1.6 vers 2.2.1 n'impacte pas la communication entre la radio et les récepteurs.
Ce qui fonctionnait avant, doit fonctionner encore.
Maintenant, comme tu as joué un peu dans tous les sens avec les version d'OpenTx et les firmwares des récepteurs, il faut remettre de l'ordre dans tout cela.

Le module interne doit avoir le firmware pour le module interne... Un récepteur doit avoir le firmware du récepteur. La seule contrainte (mais de taille) est que les deux firmware doivent utiliser le même protocole (EU-LBT ou FCC)
Donc, tu reflashes d'abord le firmware de ta radio en eu-lbt.
Puis tu reflashes le firmware de tes récepteurs en eu-lbt également.

Le protocole D8, lui, est toujours disponible dans les firmwares... Mais il est inhibé dans OpenTX si tu coches la case EU dans les préférences.
Donc, pour disposer de D8, il faut installer une version d'OpenTX avec l'option EU décochée dans les préférences...

J'espère que ceci te permettra de reprendre pied.
Bons vols !

Coyotte

_________________

Avec OpenTx 2.0, la question n'est plus "Est-ce possible ?" mais "Comment faire pour... ?"
Avec OpenTx 2.1, la question devient "Mais jusqu'où s'arrêteront-ils ?"
Avec OpenTx 2.2, on se dit "Mâtin, ils ont aussi pensé à cela ..."
Lien obligeamment prêté par le Lapin : [Vous devez être inscrit et connecté pour voir ce lien]<<<<<<<
[Vous devez être inscrit et connecté pour voir ce lien] (OO-AB1219)

Nous sommes sur un forum donc pas de support par messagerie privée :-)
avatar
CoyotteDundee

Messages : 2775
Date d'inscription : 03/03/2014
Age : 54
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par Mipel le Jeu 12 Juil 2018, 2:00 pm

Bonjour,

Quand je flashe le XSR je pioche dans le dossier Firmware et il me propose de flasher au choix module externe ou module interne.
Est-ce le même Firmware que je dois utiliser pour le module interne ?
La réponse est non, et on va tenter d'éclaircir les choses -- on reste en EU-LBT dans cet exemple :

le module interne
Si tu va sur ce lien : [Vous devez être inscrit et connecté pour voir ce lien] ou dans le pack de LapinFou sous SD/FIRMWARE/LBT/XJT, tu verras qu'il existe un firmware-XJT pour flasher le module interne de ta radio donc mettre à jour la partie "RF" (c'est à dire le module d'émisson du signal radio) mais aussi changer éventuellement le mode d'émission (EU-LBT ou FCC) donc prendre le fichier "XJT_LBT_2017-03-17.frk" dans notre cas.
Rien à voir avec la version d' OpenTx utilisée.

le module externe
Selon le type de récepteur (ici un XSR) il faudra aller dans le pack sous SD/FIRMWARE/LBT/X series et choisir le fichier "XSR_LBT_2017-06-19.frk"

Si tu ne mélanges pas les deux, tout devrait bien se passer.
Comme dit aussi dans les autres posts, la version d' OpentTx ne change rien dans tout ça, quelle que soit la version.
[EDIT] le Coyotte est rapide ce mois-ci, malgré la chaleur !
avatar
Mipel

Messages : 998
Date d'inscription : 08/06/2017
Age : 60
Localisation : Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 2:10 pm

Merci !
Je commence à voir plus clair, surtout qu'avec ces nouvelles notions j'ai trouvé plus d'info sur le forum.
Je met tout ça au propre ce soir et je vous tiens au courant.

Merci à vous !!!


avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par Mipel le Jeu 12 Juil 2018, 2:17 pm

je sens que je ne vois pas la forêt cachée derrière l'arbre

Un petit élagage et hop, la lumière revient Laughing
Nous en sommes tous passés plus ou moins par là et il faut bien reconnaître que cela demande un peu d'investissement pour assimiler les bases. Mais quand on y pense après coup, il n'y a rien de bien compliqué en fait.
avatar
Mipel

Messages : 998
Date d'inscription : 08/06/2017
Age : 60
Localisation : Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Jeu 12 Juil 2018, 10:11 pm


ça marche !!!!
Après des jours de galère et voilà ! En suivant vos indications à propos du module interne XJT que j'avais complètement occulté tout est en ordre.
Maintenant je m'atèle à l’intégration de scripts LUA en provenance de betaflight et je croise les doigts si mon montage n'est pas pourrave je devrais trouver la télémétrie via la radio. Je vous tiens au courant.

Un grand MERCI à tous !!!

En plus du coup j'ai l'impression de connaitre beaucoup mieux cette radio qui m'effrayait un peu et franchement je ne la vois plus de la même façon ce soir.


avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par Mipel le Ven 13 Juil 2018, 9:11 am

Content pour toi que tout soit rentré dans l'ordre. Pour les scripts lua, cherche un peu dans le forum, il y a des infos à gratter pour que ça se passe bien. Et si questions, il y a aussi une rubrique dédiée.
Je suppose que tu veux les pid sur ton écran Wink
avatar
Mipel

Messages : 998
Date d'inscription : 08/06/2017
Age : 60
Localisation : Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par CedG le Ven 13 Juil 2018, 9:39 am

Pid et Réglages du VTX !
Pour l'instant ça ne marche pas, je pense que nous devrions donc nous recroiser sous peu dans la section ad hoc.

Encore merci à tous et à très vite pour de nouvelles aventures !
avatar
CedG

Messages : 9
Date d'inscription : 10/03/2017
Localisation : Hauts-De-Seine

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par Mipel le Ven 13 Juil 2018, 10:02 am

Qu'est ce qui ne marche pas ? Une erreur de mémoire lors du lancement du script ?
Décris les étapes et les problèmes rencontrés dans la bonne section, on fera au mieux pour t'aider.
avatar
Mipel

Messages : 998
Date d'inscription : 08/06/2017
Age : 60
Localisation : Vendée - Aéromodélisme Sablais

http://aeromodelisme-sablais.fr

Revenir en haut Aller en bas

Re: X9D+ problème de Bind après passage en OTX 2.2.1

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum