Le forum français des radios FrSKY

S6R et Quick Mode

Page 2 sur 5 Précédent  1, 2, 3, 4, 5  Suivant

Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 12:38

Cela n'est exactement  ni l'un ni l'autre (ni aveugle ni relire chaque paquet). On positionne le récepteur en mode update, on lui envoie un paquet de données, le récepteur confirme ensuite que l'on peut continuer et envoyer le suivant et ainsi de suite. Comme les paquets inclus des contrôles de sommes, il est raisonnable de penser que si une corruption arrivait, le récepteur ralerait.

Donc a priori le flash devrait être fiable, sauf s'il existe un soucis au niveau du récepteur lui même qui l’empêche de sauver le firmware reçu sans qu'il ne s'en apperçoive.

Après dans ce cas précis, on peut imaginer qu'il existe en ensemble de situation qui fait que le récepteur de Breizh29 ne se comporte pas comme le mien, allant de la calibration (faite avec succès ou pas) ou un réglage xy sur le récepteur qui ferais que nos récepteurs ne sont pas exactement dans la même situation.

3djc
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 19:57

Bon, voilà une après midi bien occupée, mais sans grand résultat.

Ordre des manips :
1) flashage du firmware version 170706, la séquence se déroule apparemment correctement (voyant rouge et jaune clignotent en alternance). A la mise sous tension du récepteur (radio éteinte et sans aucun servo) je ne constate aucun allumage de la LED bleue indiquant qu'il est passé en Quick Mode. Raccordement de servos, allumage radio, le voyant passe au vert et le récepteur réagit en mode normal (avec voie 10 et 11). Sauf le problème du RSSI et du débattement à la mise sous tension qui sont tjs présents.

2) me disant que la version d'OTX 2.2.1 pouvait être mal chargée dans ma radio et provoquer un mauvais flashage, je suis revenu a une ancienne version que j'avais conservée : OTX 2.1.8. Reflashage : pareil

3) retour en OTX 2.2.1 puis flashage avec le firmware du 4/12/17 (dernier en date) : pareil.

Je n'arrive pas à faire passer ce récepteur à la noix en Quick Mode. Ce n'est pas tant le QM qui m'embête, je pourrais l'utiliser en normal, mais c'est surtout le fait que je ne peux pas mettre à jour et que le problèmes RSSI et autres sont toujours présents.
D'ailleurs, maintenant j'en arrive à mettre en doute toutes les mises à jour faites à partir de ma radio sur mes autres récepteurs (X8R et X6R) et je flippe à mettre en l'air ma maquette (1 an 1/2 de travail).

Je vais contacter M. Lacroix (Microtechnics) pour voir s'il est prêt à me l'échanger mais comme il n'a pas répondu à mes deux derniers mails concernant mon suivi de commande, j'ai quelques doutes (pourtant jusqu'à présent il a tjs été fiable).
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mer 14 Mar 2018 - 20:09

Moi je viens de faire un test intéressant. Ma X9D+ est à la norme FCC.
Du coup pour vérifier si le flashage fonctionne, j'ai flashé le firmware LBT.
Résultat, impossible de binder. Donc, le firmware a bien été mis à jour.
Après, j'ai reflashé avec le dernier firmware FCC, et là j'ai pu refaire le bind sans soucis (preuve que le firmware a bien été chargé). Mais, toujours pas de quick mode... Sad
avatar
LapinFou

Messages : 9546
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Eric84AMC le Mer 14 Mar 2018 - 20:14

Je vous confirme bien avec le quick mode sur mon S6R, mais peut être que le problème n'est pas le firmware mais le script lua pour le paramétrer.

J'ai fait cela il y a longtemps, de mémoire il me semble avoir utilisé cela : [Vous devez être inscrit et connecté pour voir ce lien]
avatar
Eric84AMC

Messages : 1729
Date d'inscription : 21/09/2013
Age : 44
Localisation : Monteux

http://www.amc-pernes-lesvalayans.com/index.php

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mer 14 Mar 2018 - 20:21

Le script LUA dans mon pack SD est OK, car je vois bien le Quick mode sur mon S8R et pas sur mon S6R.
Par contre, je viens de me rendre compte de quelque chose; pendant la calibration du S8R les valeurs affichées changent beaucoup (genre de -27.xx à +12.xx par exemple), alors que lors de la calibration du S6R, les valeurs sont beaucoup beaucoup plus petites (genre -0.02 à +1.15).
Sur le S6R aucune valeur dépasse +/-1.20. Est-ce que cela signifie que les gyros sont HS ??
avatar
LapinFou

Messages : 9546
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 20:29

Non, il y a une modification sur les derniers firmwares s8r. Il faut utiliser les scripts de calibration du pack v0014 qui incluent les corrections nécessaires

Attention durant la calibration, vous devez ne pas bouger le récepteur tant que la led clignote

3djc
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mer 14 Mar 2018 - 22:23

Merci beaucoup pour l'info. Je vais mettre à jour mon pack SD.
En attendant, je poste ici la correction avec la traduction en Français.
Merci aussi pour l'histoire de LED clignotante. Dans la doc FrSky (écrite Chinenglish), c'est écrit que le clignotement correspond à la fin de la calibration. Alors qu'en fait c'est "calibration en cours"... Evil or Very Mad

Sinon, tu n'as pas d'idée pour cette histoire de S6R qui refuse d'afficher le quick mode ??

albino

Code:
---- #########################################################################
---- #                                                                      #
---- # Copyright (C) OpenTX                                                  #
-----#                                                                      #
---- # License GPLv2: http://www.gnu.org/licenses/gpl-2.0.html              #
---- #                                                                      #
---- # This program is free software; you can redistribute it and/or modify  #
---- # it under the terms of the GNU General Public License version 2 as    #
---- # published by the Free Software Foundation.                            #
---- #                                                                      #
---- # This program is distributed in the hope that it will be useful        #
---- # but WITHOUT ANY WARRANTY; without even the implied warranty of        #
---- # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the        #
---- # GNU General Public License for more details.                          #
---- #                                                                      #
---- #########################################################################
local VALUE = 0
local COMBO = 1

local COLUMN_2 = 150

local edit = false
local page = 1
local current = 1
local refreshState = 0
local refreshIndex = 0
local calibrationState = 0
local pageOffset = 0
local calibrationStep = 0
local pages = {}
local fields = {}
local modifications = {}

local calibrationFields = {
  {"X:", VALUE, 0x9E, 0, -100, 100, "%"},
  {"Y:", VALUE, 0x9F, 0, -100, 100, "%"},
  {"Z:", VALUE, 0xA0, 0, -100, 100, "%"}
}

local function drawProgressBar()
  local width = (140 * refreshIndex) / #fields
  lcd.drawRectangle(30, 1, 144, 6)
  lcd.drawFilledRectangle(32, 3, width, 2);
end

-- Select the next or previous page
local function selectPage(step)
  page = 1 + ((page + step - 1 + #pages) % #pages)
  refreshIndex = 0
  calibrationStep = 0
  pageOffset = 0
end

-- Draw initial warning page
local function runWarningPage(event)
  lcd.clear()
  lcd.drawScreenTitle("SxR", page, #pages)
  lcd.drawText(0, 10, "Attention: ceci demarrera la calibration du SxR", SMLSIZE)
  lcd.drawText(0, 18, "Ceci doit etre fait une seule fois. Votre SxR", SMLSIZE)
  lcd.drawText(0, 26, "doit etre alimente et pose sur une surface", SMLSIZE)
  lcd.drawText(0, 34, "plane et de niveau (bureau, plan de travail, ...).", SMLSIZE)
  lcd.drawText(0, 46, "Appuyer sur [ENT] quand vous etes pret", SMLSIZE)
  lcd.drawText(0, 56, "Appuyer sur [EXIT] pour annuler", SMLSIZE)
  if event == EVT_ENTER_BREAK then
    selectPage(1)
    return 0
  elseif event == EVT_EXIT_BREAK then
    return 2
  end
  return 0
end

-- Redraw the current page
local function redrawFieldsPage()
  lcd.clear()
  lcd.drawScreenTitle("SxR", page, #pages)

  if refreshIndex < #fields then
    drawProgressBar()
  end

  for index = 1, 7, 1 do
    local field = fields[pageOffset+index]
    if field == nil then
      break
    end

    local attr = current == (pageOffset+index) and ((edit == true and BLINK or 0) + INVERS) or 0

    lcd.drawText(0, 1+8*index, field[1])

    if field[4] == nil then
      lcd.drawText(COLUMN_2, 1+8*index, "---", attr)
    else
      if field[2] == VALUE then
        lcd.drawNumber(COLUMN_2, 1+8*index, field[4], LEFT + attr)
      elseif field[2] == COMBO then
        if field[4] >= 0 and field[4] < #(field[5]) then
          lcd.drawText(COLUMN_2, 1+8*index, field[5][1+field[4]], attr)
        end
      end
    end
  end
end

local function telemetryRead(field)
  return sportTelemetryPush(0x17, 0x30, 0x0C30, field)
end

local function telemetryWrite(field, value)
  return sportTelemetryPush(0x17, 0x31, 0x0C30, field + value*256)
end

local telemetryPopTimeout = 0
local function refreshNext()
  if refreshState == 0 then
    if calibrationState == 1 then
      if telemetryWrite(0x9D, calibrationStep) == true then
        refreshState = 1
        calibrationState = 2
        telemetryPopTimeout = getTime() + 80 -- normal delay is 500ms
      end
    elseif #modifications > 0 then
      telemetryWrite(modifications[1][1], modifications[1][2])
      modifications[1] = nil
    elseif refreshIndex < #fields then
      local field = fields[refreshIndex + 1]
      if telemetryRead(field[3]) == true then
        refreshState = 1
        telemetryPopTimeout = getTime() + 80 -- normal delay is 500ms
      end
    end
  elseif refreshState == 1 then
    local physicalId, primId, dataId, value = sportTelemetryPop()
    if physicalId == 0x1A and primId == 0x32 and dataId == 0x0C30 then
      local fieldId = value % 256
      if calibrationState == 2 then
        if fieldId == 0x9D then
          refreshState = 0
          calibrationState = 0
          calibrationStep = (calibrationStep + 1) % 7
        end
      else
        local field = fields[refreshIndex + 1]
        if fieldId == field[3] then
          local value = math.floor(value / 256)
          value =  bit32.band(value, 0xffff)
          if field[3] >= 0x9E and field[3] <= 0xA0 then
            local b1 = value % 256
            local b2 = math.floor(value / 256)
            value = b1*256 + b2
            value = value - bit32.band(value, 0x8000) * 2
          end
          if field[2] == COMBO and #field == 6 then
            for index = 1, #(field[6]), 1 do
              if value == field[6][index] then
                value = index - 1
                break
              end
            end
          elseif field[2] == VALUE and #field == 8 then
            value = value - field[8] + field[5]
          end
          fields[refreshIndex + 1][4] = value
          refreshIndex = refreshIndex + 1
          refreshState = 0
        end
      end
    elseif getTime() > telemetryPopTimeout then
      refreshState = 0
      calibrationState = 0
    end
  end
end

local function updateField(field)
  local value = field[4]
  if field[2] == COMBO and #field == 6 then
    value = field[6][1+value]
  elseif field[2] == VALUE and #field == 8 then
    value = value + field[8] - field[5]
  end
  modifications[#modifications+1] = { field[3], value }
end

-- Main
local function runFieldsPage(event)
  if event == EVT_EXIT_BREAK then -- exit script
    return 2
  elseif event == EVT_ENTER_BREAK then -- toggle editing/selecting current field
    if fields[current][4] ~= nil then
      edit = not edit
      if edit == false then
        updateField(fields[current])
      end
    end
  elseif edit then
    if event == EVT_PLUS_FIRST or event == EVT_ROT_RIGHT or event == EVT_PLUS_REPT then
      addField(1)
    elseif event == EVT_MINUS_FIRST or event == EVT_ROT_LEFT or event == EVT_MINUS_REPT then
      addField(-1)
    end
  else
    if event == EVT_MINUS_FIRST or event == EVT_ROT_LEFT then
      selectField(1)
    elseif event == EVT_PLUS_FIRST or event == EVT_ROT_RIGHT then
      selectField(-1)
    end
  end
  redrawFieldsPage()
  return 0
end

local calibrationPositionsBitmaps = { "bmp/up.bmp", "bmp/down.bmp", "bmp/left.bmp", "bmp/right.bmp", "bmp/forward.bmp", "bmp/back.bmp"  }

local function runCalibrationPage(event)
  fields = calibrationFields
  if refreshIndex == #fields then
    refreshIndex = 0
  end
  lcd.clear()
  lcd.drawScreenTitle("SxR", page, #pages)
  if(calibrationStep < 6) then
    lcd.drawText(0, 9, "Orienter le SxR comme sur l'image", 0)
    lcd.drawPixmap(10, 19, calibrationPositionsBitmaps[1 + calibrationStep])
    for index = 1, 3, 1 do
      local field = fields[index]
      lcd.drawText(80, 12+10*index, field[1], 0)
      lcd.drawNumber(90, 12+10*index, field[4]/10, LEFT+PREC2)
    end

    local attr = calibrationState == 0 and INVERS or 0
    lcd.drawText(0, 56, "Appuyer [ENT] quand pret", attr)
  else
    lcd.drawText(0, 9, "Calibration terminee", 0)
    lcd.drawPixmap(10, 19, "bmp/done.bmp")
    lcd.drawText(0, 56, "Appuyer [EXIT] quand pret", attr)
  end
  if calibrationStep > 6 and (event == EVT_ENTER_BREAK or event == EVT_EXIT_BREAK) then
    return 2
  elseif event == EVT_ENTER_BREAK then
    calibrationState = 1
  elseif event == EVT_EXIT_BREAK then
    if calibrationStep > 0 then
      calibrationStep = 0
    end
  end
  return 0
end

-- Init
local function init()
  current, edit, refreshState, refreshIndex = 1, false, 0, 0
  pages = {
    runWarningPage,
    runCalibrationPage
  }
end

-- Main
local function run(event)
  if event == nil then
    error("Ce n'est pas un script modele !!")
    return 2
  elseif event == EVT_PAGE_BREAK then
    selectPage(1)
  elseif event == EVT_PAGE_LONG then
    killEvents(event);
    selectPage(-1)
  end

  local result = pages[page](event)
  refreshNext()

  return result
end

return { init=init, run=run }
avatar
LapinFou

Messages : 9546
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 22:59

Malheureusement (ou heureusement ?) aucun de mes s8r ou s6r ne présente le soucis, pourtant je ne les ai pas du tout acheté au même moment, donc pour l'instant j'ignore si c'est un soucis générique qui juste par hasard ne m'affecte pas, ou si quelques choses que j'ai fait fait que ca marche, ou si quelque chose que vous faite fait que ca ne marche pas.

Je pense faire une version spéciale de OpenTx pour logger l'ensemble de la télémétrie voir si ca me donne des infos

3djc

avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par thefabrice le Mer 14 Mar 2018 - 23:14

LapinFou a écrit:Le script LUA dans mon pack SD est OK, car je voie bien le Quick mode sur mon S8R et pas sur mon S6R.

bonsoir, j'ai le quick mode sur mon S6R avec ton dernier pack SD ...
avatar
thefabrice

Messages : 146
Date d'inscription : 15/07/2017
Age : 44
Localisation : poitiers

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 23:34

Je n'avais pas pensé au basculement FCC/LBT pour m'assurer que le flashage s'effectue correctement. C'est une bonne idée.
Je ferais cela demain sur le mien pour voir.
C'est qd même surprenant que certains puissent avoir le Quick Mode et pas d'autres. Mais le Quick Mode n'est pas tout, il reste également le problème du RSSI qui se balade entre 105 à 108db puis redescend à 95db sans rien toucher à l"environnement. N'était-ce pas une cause de la modification du firmware par FrSky ?
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 23:44

Est-ce que quelqu'un de ceux qui ont un S6R avec Quick Mode fonctionnel pourrait me confirmer qu'au moment où l'on alimente le récepteur tout seul sans aucun servo et radio éteinte on voit bien la LED bleue clignoter 3s comme c'est dit dans la doc.
Merci de vos retours
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par thefabrice le Mer 14 Mar 2018 - 23:52

oui, la led bleue clignote rapidement pendant 3 ou 4s environ ...
avatar
thefabrice

Messages : 146
Date d'inscription : 15/07/2017
Age : 44
Localisation : poitiers

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Jeu 15 Mar 2018 - 0:05

Merci pour ta réactivité.
Sur ce, je vais dormir, il parait que la nuit porte conseil !!!
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par thefabrice le Jeu 15 Mar 2018 - 0:17

sujet passionnant, décourageant et même énervant parfois ... pas rien ces SxR Very Happy
++
avatar
thefabrice

Messages : 146
Date d'inscription : 15/07/2017
Age : 44
Localisation : poitiers

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Jeu 15 Mar 2018 - 7:42

La vidéo de mise sous tension, radio éteinte

[Vous devez être inscrit et connecté pour voir ce lien]

3djc
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Jeu 15 Mar 2018 - 9:27

Et voici ma séquence. Pas du tout la même !

[Vous devez être inscrit et connecté pour voir ce lien]

avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Jeu 15 Mar 2018 - 9:30

OK, donc j'ai fait une version special debug du script, qui log dans un fichier les valeurs échangée ainsi que le timing. @LapinFou, pourrais tu executer le fichier joint, et me poster le debug.log qui va être crée ? (bien aller dans la page 2 pour avoir la valeur de quickmode)

3djc
Fichiers joints
S6R-debug.zip Vous n'avez pas la permission de télécharger les fichiers joints.(3 Ko) Téléchargé 11 fois
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Jeu 15 Mar 2018 - 9:32

Breizh29, je l'ai pas sur la vidéo, mais quant je met un servo en ail, il ne bouge pas du tout

3djc


Dernière édition par 3djc le Jeu 15 Mar 2018 - 9:43, édité 1 fois
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Jeu 15 Mar 2018 - 9:35

C'est ce que j'aurai voulu aussi.
Mais comme tu peux voir sur ma vidéo, le mien a des mouvements qui peuvent être dangereux pour les gouvernes.
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Jeu 15 Mar 2018 - 9:42

Peut tu détailler dans quelle condition tu a fait la vidéo ? Tu a demandé de la faire radio éteinte, or ta led verte est allumé, donc réception. De plus il semble y avoir un évenement en cours de route

3djc
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Jeu 15 Mar 2018 - 12:28

Voilà la vidéo promise. Conditions : radio éteinte, sans servo.
Vous verrez deux mises sous tension qui montrent que la LED bleue ne s'allume pas.

[Vous devez être inscrit et connecté pour voir ce lien]

J'ai également fait la manip de changement de firmware de LBT à FCC. Le récepteur ne Bind plus avec la radio.
Retour FCC/LBT. Le S6R bind a nouveau. Mais rien n'a changé dans son comportement.
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Jeu 15 Mar 2018 - 12:32

Je viens d'avoir un retour de M. Lacroix qui me précise que le récepteur avait été mis à jour et contrôlé avant l'envoi.
Il me demande aussi si j'ai bien suivi la procédure pour mettre à jour le firmware..... je ne sais pas.... peut-être... peut-être pas ! Aurais-je loupé quelque chose ?
avatar
Breizh29

Messages : 84
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Jeu 15 Mar 2018 - 12:48

J'ai désactivé le quick mode (on le vois car la bleu ne s'allume plus) Radio allumée, j’éteins et j'allume le récepteur. A un moment les servos bougent, mais c'est juste parce que j'ai été bouger les sticks pour monterer que c'est pas des servos en panne !!!

[Vous devez être inscrit et connecté pour voir ce lien]

3djc
avatar
3djc

Messages : 1782
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Jeu 15 Mar 2018 - 14:01

Dans mon cas je ne crois pas avoir vu de LED bleu sur le S8R. Par contre, j'ai juste fait des essais de calibrations/mise à jour de firmware. Je n'ai RIEN programmé pour l'instant. Toutes les voies sont à 0%. C'est peut-être lié...
avatar
LapinFou

Messages : 9546
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Ceeb182 le Jeu 15 Mar 2018 - 20:48

Je m'intéresse à votre sujet. J'ai un S8R flashé avec le dernier firmware mais je n'ai pas de S6R.
De ce que je comprends, il y a 4 points différents :
1 - l'absence de QuickMode sur un S6R flashé avec le firmware v171204 et configuré avec le script LUA
2 - le décalage des servos pendant environ 1s à la mise sous tension du S6R
3 - le script LUA de calibration qui n'affiche pas les bonnes valeurs en X, Y et Z
4 - la fluctuation de la valeur du RSSI

1 - Pour la disparition du QuickMode du S6R de @Breizh29 et @LapinFou, je ne l'explique pas !? C'est étrange d'autant plus que ceux de @Eric84AMC et @3djc n'ont pas eu ce problème.  scratch Il faudrait trouver séquence qui permet d'aboutir à ce dysfonctionnement... pas facile.
Au démarrage du récepteur, si la LED bleue clignote pendant environ 4s, le récepteur est en QuickMode. Sinon le QuickMode est désactivé.
2 - Pour le décalage des servos pendant environ 1s à la mise sous tension :
J'ai constaté le même comportement sur un S8R et aussi sur un X6R, tous les deux dotés du dernier firmware.
Juste à la mise sous-tension et pendant environ 1s tous les servos branchés au récepteur se décalent d'environ +20°.
Pour le S8R, après cette 1ere seconde les servos se décalent de -20°, puis, après la fin de l'initialisation du récepteur et si l'émetteur est allumé, les servos reprennent la position commandée.
Pour le X6R, après cette 1ere seconde les servos reprennent la position commandée.
Ensuite j'ai essayé la séquence suivante sur le S8R et X6R :
- mise sous tension puis arrêt avant la fin de la 1ere seconde => décalage d'environ +20° de tous les servos
- remise sous tension puis arrêt avant la fin de la 1ere seconde => re-décalage d'environ +20° de tous les servos (en cumul cela fait environ 40°)
Je ne sais pas si c'est normal et commun à toutes les marques.
J'ai remarqué que si le récepteur était allumé alors que l'émetteur est éteint, il n'exécute pas le Failsafe préalablement configuré avec l'émetteur. Si l'émetteur est allumé avant le récepteur il n'y a évidemment aucun problème (on peut alors éteindre la radio, le Failsafe est bien exécuté).
3 - Impeccable, la [Vous devez être inscrit et connecté pour voir ce lien]
4 - Seuls les spécialistes peuvent répondre (par exemple @3djc). Je ne m'en était pas aperçu et sur mon S8R j'ai plutôt l'impression que la valeur du RSSI reste assez stable.


Dernière édition par Ceeb182 le Jeu 15 Mar 2018 - 21:58, édité 3 fois
avatar
Ceeb182

Messages : 691
Date d'inscription : 29/10/2016
Age : 43
Localisation : France

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 5 Précédent  1, 2, 3, 4, 5  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum