Le forum français des radios FrSKY

S6R et Quick Mode

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Aller en bas

S6R et Quick Mode

Message par Breizh29 le Mar 13 Mar 2018 - 0:34

Bonjour à tous,

Quelques retours d'expériences (et quelques questions aussi) sur la configuration et les tests effectués sur un S6R que je viens de recevoir de chez Microtechnics.

J'ai passé ma radio en 2.2.1 et mis à jour le S6R avec le dernier firmware. Lorsque j'ai voulu utiliser le script LUA de configuration (que ce soit celui de FrSky ou celui en français de notre Garenne télécommandé) je me suis aperçu que la ligne "Quick Mode" n'affichait pas les options "Activer" ou "Désactiver".
On voit apparaitre fugitivement les 3 petits traits, puis la zone devient blanche. Le curseur est également invisible. En appuyant sur la touche "-" il réapparait bien sur la ligne en dessous.
Toutes les options de configuration ont l'air de bien marcher sauf ce Quick Mode.

De plus, la doc FrSky dit que lorsque l'on a fini de flasher le S6R il devrait être par défaut en Quick Mode..... pas le mien, il reste en normal. J'ai donc configuré ma radio avec Voie10 et Voie11 (en corrigeant la valeur de CH10 qui doit être inf(M-H) en vol tranche (mais je crois que le pb a déjà été identifié)) et fait les essais qui se sont correctement déroulés.

Quelqu'un aurait-il une idée sur le pourquoi du comment et surtout sur ce qui empêche de valider ce Quick Mode dans le script LUA. J'ai vérifié le script, la ligne existe bien :
 {"Quick Mode:", COMBO, 0xAA, nil, { "Desactiver", "Activer" } },

J'ai aussi constaté quelque chose qui me dérange et j'aimerai savoir si ceux qui utilisent un S6R constatent la même chose :

A la mise sous tension du récepteur, les servos bougent pour indiquer que les gyros sont initialisés, soit, mais le mouvement des palonniers est très grand (presque en butée) et si la gouverne ne peut débattre que de 80 à 90% de la course totale, alors le servo se trouve bloqué et force au risque de casser un pignon ou d'abimer la gouverne.
Cela est aussi vrai lors du self-Check.
Avez-vous aussi constaté cela ? J'aurais aimé que ce mouvement soit de faible amplitude, suffisamment pour voir la fin de l'init. mais pas trop pour pas tout abimer.

Merci de vos réponses et encore bravo a ceux qui animent ce site qui permet de comprendre bien des choses.

Guy
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mar 13 Mar 2018 - 9:57

Je viens de faire le test en mettant le firmware  S6RFCC_171204.frk, et en utilisant le script du git : [Vous devez être inscrit et connecté pour voir ce lien] Ca fonctionne corrrectement chez moi :

[Vous devez être inscrit et connecté pour voir ce lien]

D'autre part, a l'allumage, il n'y a pas de raison que les servos bougent (ça je n'ai pas testé dans la toute dernière version, mais dans les précédentes, ça n'était pas le cas), mais je tacherai de vérifier ça dans la journée
avatar
LapinFou

Messages : 9253
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mar 13 Mar 2018 - 10:51

Merci à toi.

Voila ce que j'ai sur ma radio :



Je vois que tu es sur X7 et en firmware FCC, peut-être que pour X9 et firmware EU-LBT c'est différent.

Guy
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mar 13 Mar 2018 - 11:42

La photo ne vient pas de moi.
Par contre, êtes réellement sûr d'avoir flashé ton S6R avec la dernière version ?
Utilises-tu mon pack SD ? Je suppose que oui, car le script LUA est traduit en Français.

Et pour info, c'est pareil sur une X9E:
[Vous devez être inscrit et connecté pour voir ce lien]
avatar
LapinFou

Messages : 9253
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mar 13 Mar 2018 - 11:58

Oui, le firmware est bien S6RLBT_171204.frk, c'est le dernier en date sur le site de FrSky

Oui, j'utilise bien ton script LUA du dernier pack mis en ligne

En ce qui concerne le mouvement des servos j'ai trouvé cette vidéo qui montre que lors du self-check les gouvernes vont en butée

[Vous devez être inscrit et connecté pour voir ce lien]

Guy



Dernière édition par Breizh29 le Mar 13 Mar 2018 - 12:05, édité 1 fois
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mar 13 Mar 2018 - 16:59

Apparemment oui, a la mise sous tension, les gouvernent ne bougent pas, il y a une initialisation (le voyant bleu clignote), mais pas de mouvement des commandes. En cas de self check (commandé par la voie 12), la oui, les commandes bougent.
avatar
LapinFou

Messages : 9253
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mar 13 Mar 2018 - 19:38

Glup !
Je n'ai pas du tout la même chose. Je commence à trouver cela étrange !

A la mise sous tension, j'ai le voyant rouge qui s'allume le temps que la liaison s'établisse avec l'émetteur (1/2s). Là le servo de la voie 1 (et tjs lui) fait un gros mouvement (toujours dans le même sens) puis le voyant vert passe en fixe, la liaison est alors établie et le servo revient au neutre. A partir de là tout a l'air de fonctionner.

Je suis également surpris car la doc de FrSky (dernière en date sur leur site) précise que en fonctionnement le voyant vert devrait clignoter. Le mien est fixe.
En parlant de doc je constate aussi que le mode Vol Tranche est toujours donné pour Voie10 sup(M+H) alors que c'est inf(M-H). Cette info est bonne sur une doc vue dans une vidéo Youtube (y aurait-il plusieurs docs différentes sur des serveurs différents (US ?))
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Eric84AMC le Mar 13 Mar 2018 - 20:53

Regardes ce post [Vous devez être inscrit et connecté pour voir ce lien]

A mon avis tu dois avoir l'avant dernier firmware car c'est seulement dans le dernier que le quick mode existe
avatar
Eric84AMC

Messages : 1699
Date d'inscription : 21/09/2013
Age : 44
Localisation : Monteux

http://www.amc-pernes-lesvalayans.com/index.php

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Eric84AMC le Mar 13 Mar 2018 - 21:32

Concernant les commandes qui bougent à l'allumage de mémoire j'ai cela aussi. Mais avec un ancien firmware sans quick mode.

C'est lors de l'apprentissage de la course max des servos que cela est mémorisé, donc ensuite lors des prochains démarrages les servos ne forceront plus car leur course sera limitée à la course apprise.
avatar
Eric84AMC

Messages : 1699
Date d'inscription : 21/09/2013
Age : 44
Localisation : Monteux

http://www.amc-pernes-lesvalayans.com/index.php

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 0:27

Merci à tous, je vais reprendre la procédure à 0 demain une nouvelle fois.

Le manuel de Ceeb182 m'a aidé dans la configuration initiale, mais comme je lis aussi l'anglais, je consulte également les docs du site FrSky en parallele.

Ce qui me conforte dans le fait que je n'ai pas le bon firmware c'est que le S6R ne démarre pas en Quick Mode après un flashage (ce qui est dit dans la doc constructeur), en effet la diode bleue ne clignote pas a l'init.

Je vais donc le reflasher demain mais je suis pourtant sur d'avoir utilisé le dernier firmware du 4/12/17.
Je vous tiens au courant.
Merci à tous
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mer 14 Mar 2018 - 9:24

J'ai fais un test rapide hier soir (j'ai acheté un S8R et un S6R d'occasion).
Pour le S8R, pas de souci, après mise à jour, j'ai bien le quick mode.
Par contre, j'ai le même souci que toi sur mon S6R. Impossible d'avoir le quick mode.
J'ai testé cela vite fait avant de me coucher:
1. Reflasher le S6R avec le dernier firmware sur ma carte SD → pas de quick mode
2. Reflasher le S6R avec le dernier firmware en utilisant le dongle USB FrSky (le FrUSB-3/FUC-3, pas le dongle STK) → pas de quick mode

Pour le point 2, j'ai déjà eu une fois le cas d'un RX qui ne se mettait pas à jour avec la Taranis, mais OK, avec le dongle USB).

Il faudrait que j'essaye de mette un autre firmware afin de vérifier si le S6R prend bien le nouveau firmware.
avatar
LapinFou

Messages : 9253
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 9:53

J'en suis arrivé aux mêmes conclusions que toi.
Je mettais en doute le fait que le récepteur se soit bien flashé et j'avais peur que ma liaison SPort soit HS.
Mais je me rappelle avoir vu la séquence de flashage se dérouler correctement et les voyants clignoter tout au long de la séquence.
Je me dit que le nouveau firmware n'a pas dû remplacer l'ancien.
Ce qui me fait dire cela c'est qu'en plus, je reçois par télémétrie un RSSI de plus de 100 (105 en max) ce qui me semble beaucoup. Je vois que le nouveau firmware corrige des pbs de RSSI (mais était-ce bien le même pb ?).
De là a dire que l'ancien firmware n'a pas été remplacé....
Je n'ai malheureusement pas de STK pour faire l'autre manip.
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 10:53

Bonjour

Le lapinFou a sollicité mon aide.

Je viens de faire le test, il est effectivement facile de savoir quel firmware est installé grâce au RSSI. Avec le firmware 20170512 je reçois des RSSI supérieur a 100dB pour un recpteur positionné a une dizaine de cm de la x7. Si je met le dernier (20171204), exactement dans la même position, les RSSI sont autour de 90dB

(je flashe avec le x7)

3djc
avatar
3djc

Messages : 1732
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 10:55

Rectification, on dirais qu'il y a un bug dans la gestion du RSSI de la nouvelle version :

j'ai par moment des valeurs autours de 90dB, qui passe tout d'un coup sans aucune raison entre 105 et 108dB une période, puis retombe autour de 90dB, toujours sans aucune modification de l'environement, donc pas certain que ce soit un test fiable

3djc
avatar
3djc

Messages : 1732
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 11:08

Merci 3djc.
Le Pb est que le flashage du 20171204 semble ne pas bien se passer puisque même si la séquence se déroule correctement, à la mise sous tension, le firmware semble être toujours l'ancien.
Cette après-midi je vais essayer de flasher l'avant dernier firmware récupéré sur le site de FrSky. Normalement il corrige déjà le RSSI et comprend le Quick Mode. On verra bien.
Mais j'ai un doute sur le fait que le S6R accepté le flashage quel qu’il soit. Mais attendons avant de tirer des conclusions hâtives.
Seule l'expérience est preuve en technique !
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 11:10

Content que le pb que j'ai soit reproductible. On va pouvoir peut-être avancer sans mettre en cause une panne aléatoire.
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 11:14

Non, je n'arrive pas reproduire ton soucis, le flash et le script marche à tout les coups. La seule chose que je note, c'est que le RSSI est très fluctuant sur la dernière version, soit atour de 90, soit autour de 105 avec le récepteur juste a coté de la radio (mais sans reflasher, tu laisse la radio allumé, ca 'passe' de l'un a l'autre).

3djc

ps : le hasard faisant bizarrement les choses, je suis en train de travailler sur une fonction pour enregistrer de manière 'brute' les logs de télémétrie, ça pourrais nous servir dans ce cas précis
avatar
3djc

Messages : 1732
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 11:22

Exact, dès que la fonction sera dispo, je l'implémenterai.

Merci pour ce développement.
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 11:25

Je ne m'explique toujours pas pourquoi la ligne Quick Mode du script LUA ne présenta pas les options de sélection.
Est-ce que quand le S6R est dans une ancienne version ça peut faire cela ?
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 11:29

Je vais mettre l'oscillo sur la liaison SPort cette après-midi pour voir si le dialogue s'établit bien.

Je vais aussi contrôler la tension présente en sortie de Taranis pour voir si elle est correcte.

Après ???? je sèche.
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par 3djc le Mer 14 Mar 2018 - 11:41

Breizh29 a écrit:Je ne m'explique toujours pas pourquoi la ligne Quick Mode du script LUA ne présenta pas les options de sélection.
Est-ce que quand le S6R est dans une ancienne version ça peut faire cela ?

C'est pas : 'ca peut', c'est 'ca fait'. Si on utilise le LUA sur une ancienne version, la donnée du mode n'est pas transmise, et donc le script n'affiche rien. S'il reçois l'information, il doit normalement l'afficher. Le dialogue est bon, sinon tu n'aurais aucune valeur.

3djc
avatar
3djc

Messages : 1732
Date d'inscription : 25/09/2016
Localisation : Belgique

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par LapinFou le Mer 14 Mar 2018 - 11:53

Petite question à 3djc:
Lorsque l'on flash un RX avec une Taranis, est-ce que c'est uniquement des "write" en aveugle ou est-ce que c'est une succession de "write/read/check" ?
Je pose la question car j'avais eu le cas d'un X4R qui refusait de se mettre à jour, mais j'avais un message d'erreur sur ma Taranis.

@Breizh29 :
Peu-tu essayer de flasher avec l'avant-dernier firmware du S6R (version 170706) ?
C'est le 1er firmware avec le quick mode de présent.
avatar
LapinFou

Messages : 9253
Date d'inscription : 09/09/2014
Age : 43
Localisation : Falaise

http://falaisemodeleclub.fr/

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Breizh29 le Mer 14 Mar 2018 - 12:30

C'est exactement ce que j'avais prévu de faire. Je l'ai téléchargé du site FrSky, reste à flasher. Cette AM.

pour l'instant j'ai vérifié que la tension sur le + de la liaison SPort était bonne (...on ne sait jamais) mais elle fait 7,98V donc tout à fait correcte en entrée de récepteur. j'avais peur qu'elle ne soit trop faible.

Je n'ai pas eu le temps de mettre l'oscillo sur la ligne de data, mais je suppose que si la liaison n'était pas bonne la procédure de flashage m'aurait indiqué quelque chose non ? (y a-t-il une vérif de CRC ou autre à la fin du dialogue ? est-ce un "Write" a l'aveugle ou par Write/Acknowledge ? cela je ne le sait pas).
avatar
Breizh29

Messages : 75
Date d'inscription : 11/07/2016
Localisation : Finistere

Revenir en haut Aller en bas

Re: S6R et Quick Mode

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum