Le forum français des radios FrSKY

LUA pour quadri

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

LUA pour quadri

Message par diiity le Ven 8 Sep 2017 - 12:16

Bonjour,

Est ce que vous connaissez ce script très intéressant?

[Vous devez être inscrit et connecté pour voir ce lien]

C'est pour régler les FC, PID et vTx d'un quadri à partir de la radio.

Est ce que certain l'utilise et avec quel carte et quel récepteur?
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par Ludo44 le Sam 9 Sep 2017 - 10:19

Bonjour,

je l'utilise avec une carte Matek F405 et un XSR, au début, j'ai eu beaucoup de mal a le faire fonctionner, puis, après avoir flashé le RX avec le dernier Firmware, ça fonctionne sans soucis.

il faudra juste bien respecter l'arborescence des fichiers dans la radio.

par contre, si tu a un TRamp HV première génération, tu ne pourra pas régler les fréquences du VTX a partir de la radio.
avatar
Ludo44

Messages : 14
Date d'inscription : 18/12/2013
Age : 52
Localisation : Vallet, 44

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Sam 9 Sep 2017 - 10:35

Bonjour,

Moi, je suis avec une carte un peu vieillotte, flip32 AIO flight controller acro & pro v1.03 et un X4R.

Mon souci est que je n'ai pas le schéma des branchements.

Sur la carte , il y a GND, TX, RX et 5v et sur le X4R, il y a S.PORT, +, -, et AIN.

Bon pour +, -, GND et 5v pas de souci mais les autres...

Je serais bien tenté de faire des essais mais j'ai peu de cramé

Aurais tu une idée?
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par Ludo44 le Sam 9 Sep 2017 - 12:05

"une carte un peu vieillotte", tout est dit !!

regarde la: [Vous devez être inscrit et connecté pour voir ce lien]

peut être un début de piste... je pense qu'il faut que tu active "softserial" via le CLI, puis onglet "configuration", activer TELEMETRY et SOFTSERIAL,

ensuite onglet "port", sous "telemetry outpout", sélectionner "smartport"

et après, connecter le smartport de ton X4R a un pad rx de ta carte.

Tu ne risque rien si tu te trompe avec le smartport de ton rx, tant que tu ne connecte pas celui-ci a un +,  

n'oublie pas de faire "save" a chaque etape. Apres, il y a bien longtemps que j'ai "abandonné" ce type de carte au profit des cartes F4
avatar
Ludo44

Messages : 14
Date d'inscription : 18/12/2013
Age : 52
Localisation : Vallet, 44

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Sam 9 Sep 2017 - 12:17

merci pour ces tuyaux, là j'ai pas trop de temps mais je te tiens au courant
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Dim 10 Sep 2017 - 19:50

Voici des nouvelles.

J'ai activé la télémétrie et le softserial.
Dans le cli j'ai tapé softserial commande non reconnu
J'ai fait un help, il n'y a que serial et serialpassthrough, j'ai essayé ce dernier mais il manque des données à cette commande.

j'ai été voir sur le lien que tu m'as donné, certaines commandes ne fonctionne plus.

Le souci, c'est la config de port de communication car dès que je relie le RX avec la Fc au port de télémétrie, il ne s'ouvre pas dans bétaflight.


avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 11:57

Bonjour
J'ai eu une carte Flip32+. Le SBus se branche sur l'entrée RC4 et la télémétrie sur l'entrée 6. Mais attention il faut inverser le signal Sbus avec les récepteurs Frsky...

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Lun 11 Sep 2017 - 13:56

Bonjour,

Tu es sur que c'est le S-bus et pas plutôt le S-port
Qu'appelles tu entrée RC4 et 6?

Et l'inversion mais comment?

Je joins la doc

[Vous devez être inscrit et connecté pour voir ce lien]
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 14:57

Oui c'est bien du SBus que je parle mais je n'avais pas le même modèle de Flip32 que toi.
D'après la doc de ta carte, le Sbus se connecte sur le connecteur UART2 Soft Serial2.
Pour la télémetry effectivement ça a l'air d’être l'UART1.
Pour le SBus, Il faut un inverseur de ce genre là :
[Vous devez être inscrit et connecté pour voir ce lien]
Ou ça :
[Vous devez être inscrit et connecté pour voir ce lien]

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Lun 11 Sep 2017 - 16:33

J'ai fait un essai avec le lua bétaflight ça marche en me connectant sur l'entrée TX du softserial1 RGB LED.

Du coup je ne peux plus connecter de led.
Y a t il un autre moyen?

Pour softserial2, comment le vois tu?
De pluq dans bétaflight, je n'ai que softserial 1.

avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 16:41

Tu as bien mis la dernière version de Betaflight pour ta carte ?
Tu as bien validé SOFTSERIAL dans l'onglet Configuration / Other features ?

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Lun 11 Sep 2017 - 17:33

voici des captures

avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 18:34

Ça a l'air correct mais je te confirme qu'il faut connecter le Sbus avec un inverseur sur le connecteur repéré UART2 Soft serial2, ça libèrera le connecteur pour les leds.
Pour soft serial 2 je ne vois pas, tu as essayé de taper la commande "enable softserial2" ?

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 18:36

Il semble qu'il y ai aussi une modif à faire sur le jumper J15...

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Lun 11 Sep 2017 - 19:14

Ok pour l'inverseur, je le commande.

Pour enable softserial2, il me dit commande inconnu

Je te joins la liste des commandes que j'ai copié à partir de help.

Donc je si comprends bien il faut que je shunte J15 pour avoir softsérial2.
Fichiers joints
help cli.txt Vous n'avez pas la permission de télécharger les fichiers joints.(1 Ko) Téléchargé 1 fois
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Lun 11 Sep 2017 - 21:08

Oui, essaye de voir ce qui se passe en faisant la modif sur J15

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Lun 11 Sep 2017 - 21:23

Je l'ai fait, rien de particulier, si je me branche en UART2 softserial2 ça ne marche pas.

Je suis revenu à l'autre et là ça marche toujours.

Il doit y avoir une manip supplémentairer pour voir apparaître softserial2 dans bétaflight
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par Ludo44 le Mar 12 Sep 2017 - 5:49

pour le SOftserial 2, je ne suis pas sur qu'il y en ai un sur les cartes a processeur F103, mais je peux me tromper..
pour les led, tu peux essayer de remapper la fonction sur la sortie moteur 5
avatar
Ludo44

Messages : 14
Date d'inscription : 18/12/2013
Age : 52
Localisation : Vallet, 44

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Mar 12 Sep 2017 - 7:17

D’après la doc de la carte il y a bien 2 softserial.
Il faut déjà faire apparaitre softserial 2 dans l'onglet Ports de betaflight.
Enfin le RX branché sur l'entrée UART2 softserial2 ne fonctionnera pas en SBus tant qu'il n'y aura pas d'inverseur...

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Mar 12 Sep 2017 - 8:22

Ludo44 a écrit:pour le SOftserial 2, je ne suis pas sur qu'il y en ai un sur les cartes a processeur F103, mais je peux me tromper..
pour les led, tu peux essayer de remapper la fonction sur la sortie moteur 5

Et comment fais tu pour rediriger?
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Mar 12 Sep 2017 - 8:26

christian26 a écrit:D’après la doc de la carte il y a bien 2 softserial.
Il faut déjà faire apparaitre softserial 2 dans l'onglet Ports de betaflight.
Enfin le RX branché sur l'entrée UART2 softserial2 ne fonctionnera pas en SBus tant qu'il n'y aura pas d'inverseur...

Oui mais voila, comment faire apparaître softserial2, comme j'ai dis plus haut, il y a peut être une commande cli.

J'ai essayé "serial", il me donc juste cela
# serial
serial 0 1 115200 57600 0 115200
serial 1 0 115200 57600 0 115200
serial 30 32 115200 57600 0 115200
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Mar 12 Sep 2017 - 8:37

Sur cette vidéo le gars il a bien softserial2 mais je ne comprends pas comment il a fait

[Vous devez être inscrit et connecté pour voir ce lien]
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Mar 12 Sep 2017 - 9:49

Juste pour voir, essaye de déactiver OSD et VTX dans l'onglet configuration

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par christian26 le Mar 12 Sep 2017 - 9:52

...et regarde si tu n'as toujours que softserial 1

christian26

Messages : 18
Date d'inscription : 17/06/2015
Age : 62
Localisation : Bourg-lès-Valence

Revenir en haut Aller en bas

Re: LUA pour quadri

Message par diiity le Mar 12 Sep 2017 - 10:29

oui, c'est toujours là.

Je ne comprends pas comment on peut avoir softserial 1 et pas les autres, 2,3...
avatar
diiity

Messages : 980
Date d'inscription : 21/04/2015
Age : 64
Localisation : beauvais

Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum