Le forum français des radios FrSKY

Bug avec la carte SD

Voir le sujet précédent Voir le sujet suivant Aller en bas

Bug avec la carte SD

Message par Patrick74 le Jeu 24 Nov 2016 - 18:38

Hello,

J'ai conseiller à un ami la Taranis X9D Plus. On vient de la recevoir et quasi à chaque fois qu'on accède à la carte SD (pour l'écriture surtout) ça fait planter le port USB et la Taranis ?!?!?! Essayé sur 2 pc, +chez moi pareils ?!?!?!

Vous auriez pas une idée? Le bootloader peut-être? Elle est en bootloader version 2.1.6

Par contre, pas de problème avec la carte SD en direct sur le PC et la mise à jour du firmware 2.1.9 a passé sans problème

Si vous avez des idées, elles sont les biens bienvenues...
A+
Patrick

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Murphy le Jeu 24 Nov 2016 - 19:54

Bonjour,

Le port USB de la Taranis n'est pas ce qu'il y a de mieux. Par contre la carte SD de 1Go livrée avec n'est pas mieux non plus. Autant investir dans une 4Go classe 10 carrément.

_________________
Encore là...
X9D+ non EU 2.2.0,
Horus EU-LBT 2.2.0
[Vous devez être inscrit et connecté pour voir ce lien]
Forum du club [Vous devez être inscrit et connecté pour voir ce lien]
et [Vous devez être inscrit et connecté pour voir ce lien].
avatar
Murphy
Modérateur

Messages : 6332
Date d'inscription : 27/08/2013
Age : 72
Localisation : Montbéliard, près de la Suisse

http://bethoncourt-indoor.forumgratuit.org/

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Jeu 24 Nov 2016 - 20:29

Merci pour ta réponse.

J'ai mis ma propre carte mémoire et ça fait pareils, alors que sur ma radio ça passe bien ?!?!?! J'ai mis un super carte mémoire pour le 4K et ça foire aussi !  Là j'ai un doute que ça soit la carte mémoire Sad

On peut mettre un bootloader à jour ? On fait ça comment?

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Jeu 24 Nov 2016 - 20:38

oui mais comment qon fait Razz

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Jeu 24 Nov 2016 - 20:43

Vu Very Happy


Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Jeu 24 Nov 2016 - 21:25

Ben ça va pas mieux Sad . Avec la carte d'origine ça fait même planter le PC. La carte SD HCI 4K pareils. Avec la mienne (ancienne 2Go Taranis) ça passe mais c'est super lent 130ko/s -> 3 minutes 30sec. pour 28Mo ?!?!?!

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Murphy le Jeu 24 Nov 2016 - 22:59

Il faut formater la carte en FAT32 après avoir fait une sauvegarde...

_________________
Encore là...
X9D+ non EU 2.2.0,
Horus EU-LBT 2.2.0
[Vous devez être inscrit et connecté pour voir ce lien]
Forum du club [Vous devez être inscrit et connecté pour voir ce lien]
et [Vous devez être inscrit et connecté pour voir ce lien].
avatar
Murphy
Modérateur

Messages : 6332
Date d'inscription : 27/08/2013
Age : 72
Localisation : Montbéliard, près de la Suisse

http://bethoncourt-indoor.forumgratuit.org/

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Ven 25 Nov 2016 - 9:49

C'est vraiment une catastrophe cette connexion à la carte mémoire. Je pensais pas qu'un simple accès à une carte SD puisse faire planter le PC et la Taranis.

La carte qui fonctionne le mieux (copie à ~130ko/s) c'est la mienne, d'origine une 2Gb SD simple.

1Gb SD HC d'origine ne passe pas du tout, essais en FAT, FAT32, alloc fichiers différents. Rien ne passe avec la Taranis!
32Gb SD HCI U3 ne passe pas du tout également.
8Gb SD HC Class6  ça passe (copie à ~150ko/s), mais l'explorateur s'affiche tout lentement. Comment ça se fait?


Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par syrus_77 le Mar 13 Déc 2016 - 23:52

Salut,

j'ai eu le meme soucis (rev B01), carte illisible et radio planté lors des accès SD.

j'avais mis a jour le firmware avec companion.

J'ai simplement sortie la carte SD, je l'ai formatée à l'aide d'un lecteur de carte USB,
j'ai re-téléchargé le contenu de la carte sur le site de frsky en .zip, que j'ai extrait.

Dans un répertoire a part, j'ai copier les répertoires utile du .zip (bmp,log,model,sound), ajouter les voies fr,
puis, toujours avec le lecteur de carte branché en usb, recopier le tout directement sur la carte SD.

Remise en place de la carte, allumage et connexion de la radio en usb.

maintenant tout fonctionne sans problème, j'espère que tu aura le même résultat.

syrus_77

Messages : 6
Date d'inscription : 06/12/2016
Localisation : Provins

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Mer 14 Déc 2016 - 0:08

Salut,

Merci de ton aide,mais tu sais j'ai tout essayé. Même le formatage de la carte en dehors posait problème. Et plus je mettait une carte de qualité plus ça foirait...?!?!?!

Là? 8Gb SD HC Class6 (le premier prix que j'ai trouvé), ça passe (copie à ~150ko/s), mais windows a du mal à synchroniser, c'est super lent.

PS. J'espère que la plaque-mère ne souffre d'aucun autre défaut, car la personne va l'utiliser pour du gros (2 à 4m).

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par syrus_77 le Mer 14 Déc 2016 - 0:57

je viens de tomber sur une page qui dit qu'il faut changer de firmware :

Les Taranis Plus FrSky reçues dans la dernière livraison, sont flashées avec OpenTX 2.1.6.

Suite à notre remontée d’information au fabricant indiquant l’impossibilité de connecter correctement la radio au PC et donc de flasher OpenTX en utilisant CompanionTX ; Frsky a effectué les tests nécessaires et a trouvé la solution.

Le problème provient d’un bug dans le bootloader dans la version 2.1.6 d’OpenTX. Ce bug a pour conséquence d’empêcher la reconnaissance de la radio par le PC et ainsi la communication ne se fait pas.
[Vous devez être inscrit et connecté pour voir ce lien]

j'ai telecharger les nouveau FW sur le site de frsky, je test ca demain Sleep

syrus_77

Messages : 6
Date d'inscription : 06/12/2016
Localisation : Provins

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Mer 14 Déc 2016 - 1:05

Bha...? pareil...  Bootloader en 2.1.9 et c'est pareil...
PS. Qu'en je vous dit que j'ai tout essayé, c'est que j'ai tout essayé...

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par CoyotteDundee le Mer 14 Déc 2016 - 9:57

Hello Patrick,

Qu'entends-tu par "Même le formatage de la carte en dehors posait problème" ?

Coyotte
avatar
CoyotteDundee

Messages : 1843
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Mer 14 Déc 2016 - 10:23

La carte SD directement sur le PC. J'ai essayé plusieurs type de formats (de formatage). Certaines fois ça faisait planter le PC Mad

J'ai testé plusieurs type de carte mémoire, et j'ai eu des fonctionnements différents entre elles (sur la Taranis connecté au PC).

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par CoyotteDundee le Mer 14 Déc 2016 - 11:17

... Si tu as des problèmes avec la carte directement sur le PC, il n'est pas impossible alors que la radio soit hors de cause...
Pour lire et écrire les cartes SD directement, utilises-tu un de ces petits lecteurs branché sur l'USB ? ou est-ce le lecteur de cartes SD du PC qui est utilisé ?
avatar
CoyotteDundee

Messages : 1843
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Mer 14 Déc 2016 - 11:36

Sur le lecteur de carte du PC (pour faire des essais de formatage)

Mais en faite j'ai racheté une nouvelle carte SD pour remplacer celle d'origine. La moins chère que j'ai trouvé (SanDisk SDHC 8Gb Class6).

Ce qui est bizzare, c'est qu'il se passe presque 10 secondes pour voir apparaître cette nouvelle carte et la Taranis dans l'explorateur windows.

Par contre, c'est instantané si j'utilises la carte SD de ma vieille Taranis.

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par CoyotteDundee le Mer 14 Déc 2016 - 12:00

Regarde un peu dans les tâches s'il n'y en a pas une qui bouffe toutes les ressources de ta bécanne...
Sait-on jamais...
Parce que si la carte seule met 10 secondes à être reconnue, la Taranis n'est probablement pour rien dans l'affaire...
Pas testé sur une autre bécane ?
avatar
CoyotteDundee

Messages : 1843
Date d'inscription : 03/03/2014
Age : 53
Localisation : Montegnée (Liège)

http://blog.baily-fouss.be/

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Mer 14 Déc 2016 - 12:14

Non non, le soucis est présent selon le type de carte utilisé sur cette Taranis Plus.
Faudrait que j'essaies ces mêmes cartes sur mon ancienne Taranis pour voir ce que ça donne.

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par ceuse le Mer 14 Déc 2016 - 12:56

le débit d'échange de la SD sur la Taranis est extrêmement lent.

ceuse

Messages : 404
Date d'inscription : 31/01/2016
Age : 71
Localisation : Colombes 92700

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Baldoch le Ven 13 Jan 2017 - 21:42

Salut
J'ai une taranis x9d plus depuis peu, j'ai eu le même problème transfert de données super long et plantage du transfert vers la SD via le cable usb.
Sur le site FR SKY RC il y a un doc de lancement rapide pour la x9d + ,pour mon cas, il préconise de charger les données sur la carte en retirant la carte de la radio
et en utilisant un un lecteur de carte SD. Pour mon cas avec un lecteur de carte SD externe ça fonctionne bien.

A+

Baldoch

Messages : 10
Date d'inscription : 02/01/2017
Localisation : 38

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Patrick74 le Ven 13 Jan 2017 - 21:47

Ce qui n'a pas fonctionné très bien dans mon cas.
Et puis si il faut à chaque fois retirer la carte pour charger quoique ce soit, c'est pas top.

Patrick74

Messages : 476
Date d'inscription : 21/11/2013
Localisation : Boudry/CH

Revenir en haut Aller en bas

Re: Bug avec la carte SD

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum